Sketchup Export Problem and Suggested Improvements

I’ve been needing to export models (shop interiors, nothing too complex) to Sketchup recently.

Mostly the export plugin is great (eg it you have applied a transparent material, it gets translated, great for windows).

The main problem I came up against is that a things like closed polysurfaces (eg a cube) get exported to separate faces - which means that everything you make as a solid becomes very difficult to select and edit in Sketchup.

The way I have found to work around it is to make everything into a block, which translates as a Sketchup Component (the equivalent of a block). This is not ideal, as it adds extra preparation work before export, but it does work.

If anyone is working on improving the Sketchup plugin please can I suggest a couple of improvements - Instead of having to make blocks, would it be possible for objects that are a single entity in Rhino (eg a cube) to be exported so that they become a Group in Sketchup - ie the faces of the cube stay connected and are treated as a single object, and you can then easily select and edit them in Sketchup? Also, could items that are already a group in Rhino be exported to a group in Sketchup? And could the same view current in Rhino when you export (I always export from Perspective, which is similar to the standard Sketchup view) be set as the starting view in Sketchup please?

The other problem I have just come up against is that closed polysurfaces that include trimmed surfaces do not come across correctly in Sketchup when converted to Blocks - they have some missing faces.

But the same geometry when not a block comes across fine (but then it is separate faces, so I’m back to my original problem). I’ve also tried converting the problem polysurface to a mesh - the same thing happens - the mesh goes over fine, but the mesh within a block is missing some faces.

The Rhino file is here: <a class=“attachment"href=”//aws1.discourse-cdn.com/mcneel/uploads/default/original/3X/4/d/4da8883c686c8bc123ef381506822ad3eae6649c.3dm">ExportProblem.3dm (1.2 MB) and the Sketchup export is here: ExportProblem - SKP.7z (26.4 KB) (had to .7Zip it as cannot upload .SKP files - I have opened and saved in the file in Sketchup 8 so that the objects are centred in the view - the export is to v8 of .SKP so I think there would still be the same problem in Sketchup 2015 but I have not checked as I dont have it installed).

Any suggestions or ideas please, thanks,

Jonnie

I do get the same error as you when exporting to Sketchup. I didn’t download or try your file, but did convert a motorcycle I drew in solids and exported that to a 3DS file. The file came in properly in sketchup, parts as single closed meshes as they should be. I don’t know if this will give you all the information you need as I don’t know the different limitations of the two formats.

Edit: I did try your file, it came into sketchup as all one item. I don’t use sketchup so I don’t know if it is just a group and you can ungroup them. But hopefully this helps.

Thanks ra_mull, I will try .3DS and see how that works.

Just tried it, but I dont think its the solution - the first problem is that the layering is lost. Then, all four items in my sample file are brought in as a single component - they should be four separate items in this case. They are all complete though. The geoemtry isnt so nice though (the long thin triangles created to convert to .3DS would normally be simplified into a single polygon by the Rhino exporter).

I’m by no means a Sketchup expert but when I opened the uploaded .SKP file in Sketchup (I didnt import it - if you do, it behaves like you’d expect from CAD or Rhino - it turns the imported file into a component (block), I got two components and two separated faces versions of the beams (the uploaded file is 4 versions of a beam).

Export problems here too.

DWG format works perfectly, but I need an SKP format to import into other software for heat/light analysis. The export is not maintaining the watertight edges, which are needed for analysis.
Building_2.2.dwg (382.1 KB)

Any help/ideas with this? Rhino 5 SKP export causes problems, but the Rhino 6 version is truly awful.

  • Pascal, who would be the person to ask about the SKP exporter??

Thanks,

David

Anyone more knowledgeable than me able to shed some light on these SKP export issues?

Pretty please…

there’s a settings in the sketchup export dialog that is on by default. I don’t remember the exact wording but it’s something about planar surface.

turn that off when exporting.

if you have curves drawn directly on surfaces in rhino, things can go wonky once sketchup’ auto merge gets ahold of it.

Hi Jeff,

Thanks for the feedback. Should have said that I tried all the export options, but still the same problem exists, which is why I was wondering whether it is a problem/bug with the exporter itself…?

So when checking that the geometry is all-good in Rhino, exporting to SKP and then reimporting the SKP file to Rhino should produce the same geometry yes? It does with DWG. But using SKP produces naked edges and surfaces with certain edges not correctly trimmed.

hmm. ok.
I’m not at a computer right now. I’ll look at it more thoroughly tonight to see if I can figure out a way to get it to work right

Appreciate your efforts Jeff. I’m on Windows Rhino btw…

i’m not exactly sure what your actual problem is but if i import your .dwg into rhino… then export it to sketchup… then re-import that .skp into rhino… it’s still a solid / watertight…

can you outline your problem in a little more detail? providing the .3dm and .skp

not really… when exporting to sketchup, the geometry is converted to a (triangulated) mesh… so when bringing it back into rhino, it’s going to have these triangulations as well.

i suppose you could explode then manually rejoin desired surface then merge the faces to get back to the original rhino state but that’s going to take a lot of time.

idk, personally, i never go sketchup->rhino… i will go from rhino to sketchup sometimes for rendering reasons though.

Hi Jeff,

Just double checked this to be sure I wasn’t losing my mind, but here I am not seeing the SKP file reimported as a watertight solid. Have tried importing as a mesh and as trimmed planes, latter being preferred really. Both versions have naked edges.

The geometry was created originally in SKP but had errors, so I am trying to repair it in Rhino for a customer and re-export a SKP version.

It’s not just the re-import into Rhino that isn’t working here, it’s also the environmental software of our end-user that isn’t accepting the exported SKP files because of the naked edges.

DWG works perfectly, and is exactly as the 3DM file.

Thanks for looking into this. Are you on MAC?

yeah, I’m on Mac.
there was another sketchup issue posted here recently which worked ok on Mac and not Windows.
so I might not be of much use here :wink:

Cheers Jeff,

Appreciate it nonetheless. Do you know if the SKP exporter is McNeel work, or third party?