Rhino Rendered View Problem

Hi guys,
My Rhino 6 is acting strange and it probably has to do with my laptop (it’s a Dell Inspiron). It meets the minimum requirements for Rhino, but the rendered view keeps messing up. It displays correctly at first, but begins to copy itself when I move. Is there anything I can do to fix this? Maybe make rendered view less intensive?

It’s impossible to know if you’re asking your display adapter to do more than it’s capable of, or if there is a potential problem with the driver.

Please run the Rhino “SystemInfo” command and post the results.
That will tell us about your setup and what you’re running in Rhino.


Rhino 6 SR19 2019-10-22 (Rhino 6, 6.19.19295.01001, Git hash:master @ 0af62045bd35259d4c2367dbf7f9ef94ded29299)
License type: Evaluation, build 2019-10-22
License details: Stand-Alone
Expires on: 2020-01-24

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-1H3G5M7

Hybrid graphics system.
Primary display: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 2-28-2019 (M-D-Y).
Primary OpenGL: NVIDIA GeForce MX150 (NVidia) Memory: 2GB, Driver date: 12-12-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 417.37

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-12-2018
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\Neill\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot8RhinoPlugin (6c7d7caf-b4ba-406d-bfaa-8d719d8212c3)\\KeyShot8RhinoPlugin\Rhino 5.0\KeyShot8RhinoPlugin.rhp “KeyShot8RhinoPlugin”
C:\Users\Neill\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I’d start with updating the drivers for both of your display adapters.

Here’s a link for the Intel from 18 October:

If it gripes about not being validated for you computer, here’s the work-around for that:

Here’s a driver from today:

Any luck?

If not, it could be the Keyshot or Vray plug-ins interfering too, but I’d start with the drivers.

I updated the driver and restarted my computer and it still is happening. If it is Vray or Keyshot, what can I do to fix that?

Hello - the first thing would be to disable one or both of these (Vray, Keyshot) in Options > Plug-ins page and then restart Rhino and see if the problem persists without the plug-ins.


Hey Pascal, I tried that and it still doesn’t work

Hello - another thing to try is to force the hybrid system to always use the nVidia card - that would be a setting in the nVidia control panel, maybe ‘High performance’ - something like that.