Rhino Render using only CPU not GPU

Hi, every time I try and render using Rhino Render, my computer only uses my cpu and never any of my gpu. I’ve looked online but cant find anything that changes how to use my gpu for rendering, is anyone able to help me? I have a thinkpad p51 laptop.


What display adapter do you have?
Does it have CUDA cores or support OpenCL?

Intel® HD Graphics P630 and also
NVIDIA Quadro M2200

Rhino Render is a CPU-only renderer. If you are looking for the GPU-rendering feature it is called the Raytraced viewport mode. You can use the commands _ViewCaptureToFile and _ViewCaptureToClipboard to get different resolutions out from a Raytraced viewport.

To ensure Raytraced uses your GPU you need to set the render device to your GPU (CUDA) under Tools >> Options >> Cycles

When i hit “render” button it use 100% cpu, 0% gpu. Why Rhino Render is a CPU-only renderer? GPU is better for rendering.

So, I’ve switched viewport to raytraced (it use GPU but only 20%, why not 100?), then when it says “completed” I’ve used command _ViewCaptureToFile but it started window with “rendering vieport” and progress bar and used only cpu (20%). It works without “rendering vieport” window but only when it is not on transparent background. Is it possible to make render with GPU and transparent background?


If you have a CUDA supported GPU (anything after Fermi), or AMD with architecture GNC 2nd or newer Raytraced can use it, if set to do so. Check under Tools » Options » Cycles.

Paste the text created by the Rhino command _SystemInfo if you want.

Also, the task manager of windows won’t show correct GPU usage, for that you should use GPU-Z or MSI Afterburner.

1 Like

It looks that all is set rhight. It uses GPU but only when background is not transparent. Other case it uses CPU.

Rhino 6 SR14 2019-5-7 (Rhino 6, 6.14.19127.17141, Git hash:master @ 5b633aaa430941b76f5789a0ce3bb670ce06947a)
License type: Commercial, build 2019-05-07
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: SWAC

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 3-1-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 419.35

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-1-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

GPU-Z show it better. You were right. It use around 35-80% GPU when rendering raytraced viewport.

But there is weird color inside surfaces on raytraced render. Why? How to fix it?

1 Like

Those are backfaces you’re seeing with the silvery bits. Raytraced has slight problems with those. Make sure your objects have the slightest thickness instead of being single surfaces. You can add thickness in the object properties panel using the thickness modifier. Something like 0.001 should be fine.

1 Like

Thanks. It works.

Cool. I thought I had made a fix for that already in the raytracing code, but apparently it no longer exists. Reflective material on backfaces are problematic at the moment, so make sure you don’t see backfaces of objects with reflective material. This thickness is one way to do it :slight_smile: Your object is still single surface in Rhino, but the Raytraced mode gets a slightly different render mesh from your object, with that thickness applied.