Raytraced not utilizing GPU

I’ve been doing a few renderings using Raytraced and they’ve turned out great, though quite time consuming although simple. Whenever I render, I’ve noticed the CPU shoots up to 100%, whereas the GPU stays at 0. I’ve made sure RT is using the GPU under CUDA in options, verified by the text at the bottom of the viewport next to cycles. Screenshot of GPU-Z showing 0% GPU load and systeminfo is attached.

Rhino 6 SR18 2019-9-23 (Rhino 6, 6.18.19266.14201, Git hash:master @ 3d84f88dec99b2f4e8b7497e739ed2adc2ba8ef6)
License type: Evaluation, build 2019-09-23
License details: Cloud Zoo. In use by: Oliver ()
Expires on: 2020-01-01

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-JN591N5J

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 4-30-2019 (M-D-Y).
Primary OpenGL: NVIDIA Quadro T2000 (NVidia) Memory: 4GB, Driver date: 7-3-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.40

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-3-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Are you sure you’ve set Rhino to use the NVIDIA?

Laptops tend to prefer the integrated intel graphics card. Also I think power management could switch between them if you’re on battery.

Not sure if there’s any other way to verify this. I’ve kept an eye on the integrated graphics as well, the load there moves between 1% and 15%. I would imagine that it’d be more if it was trying to do raytraced rendering.

capture Capture

This is changed if you go to desktop right-click and there will be Nvidia Options or something similar.


A window will open and in there you can see 3d applications or something like that I don’t have English PC in front of me now.


when you click that find Rhino and make sure it uses the NVidia.

I doubt that has much to do with CUDA, that’s totally different than routing OpenGL through the add-in card.

I would question if there’s enough video memory to actually get GPU rendering working, test it on a trivially low polygon scene.

When you say you do a render, do yu mean the Rhino command _Render that pops up the render window? If so then that isn’t using Cycles at all. If you want to get a file from whatever you have in your Raytraced viewport you can use -_ViewCaptureToFile.

This is where I go to render, and it seems to use only cpu. ViewCaptureToFile used GPU and finished the job in 2 minutes under roughly 65% load. Is there a more intuititive way to use cycles with GPU?

Also, I don’t really have a reference as to what sort of speed I should be expecting from my Quadro T2000.TEST.3dm (347.4 KB) I’ll link the .3dm. I’d love some input.

The Rhino Render in v6 does not use Cycles as the render engine. The engine driving Rhino Render in v6 is CPU only.

You could use _TestPackageManager to install Rhino Render Next that bridges the gap to the _Render command for Cycles. It may be more intuitive for you to work with. Note though that for larger renders (say 4k and larger) there are some drawbacks timewise, but it should get you started at least.

In v7 Rhino Render will be handled by Cycles, you can test that already with the Rhino WIP.

Your test model isn’t particularly complex for Cycles, so you won’t see full 100% utilization yet. Hopefully in v7 once I rebase our patches onto the latest of upstream Cycles from Blender and switch to tiled rendering. That way the kernels can do ‘work stealing’, which would ensure better render device utilization.

Your test scene on my RTX 2070 at 941x526 took 1m29s for 1500 samples.

Very grateful to everyone for the extensive help, I apologize for the late reply. I’ve got a better understanding of how rendering works now, from recommendations I’ll look further into third party rendering software such as VRay.