Rhino render not rendering texture

texture
rendering

#1

I have been trying to make use of some free models of people from the 3D sketchup warehouse. Several of them are fine, but a few either don’t show their textures initially or in the case of the one attached, even though the texture mapping is showing, it does not render.

I have tried numerous things to get it to work but I am no expert.

Can anyone help?CMan0007-HD2-O02P07-S_STD.3dm (7.0 MB)


#2

So, I found a solution. Even though the textures were showing in the viewport, it would not render. The solution is to not embed textures on import so that the texture is visible as a separate jpeg. You then have to create a new material and assign the jpeg texture file to it. Then apply it to the model.

Oh, there was one other step - rhino didn’t like the long file name of the jpeg so that had to be shortened too.

It seems there are a number of bugs here!!

@dan @pascal


#3

is there any fix on the horizon for this? I’ve just tried googling for a fix for the same problem and this thread I started 1.5 years ago is the top hit.

It really isn’t good enough that this is so broken and has been for so long.


#4

@dan @pascal

For clarity, here are two images. The first shows what you get from the ‘render’ viewport setting. The second is what you get when you hit render.

I think it is reasonable to expect that textures rendered in the viewport should also be rendered when choosing to output a render.


(Pascal Golay) #5

Hi Robin - that would seem reasonable - my initial test works OK here, I’ll poke at it some more.

@robinp - is the file in the images above one that comes from another machine, or is it all (including textures) local?

-Pascal


#7

Hi @pascal my earlier work around doesn’t seem to work with this latest model. Attached is the file I’m currently trying to get working. The textures are included in the sketchup file. The same result occurs whether the textures are embedded or not. Even when they are not, I cannot manually reattach them to the materials.

I have even tried changing the file names to remove any special characters.

Whatever I do, I cannot get the books to render with the textures.

Books.skp.zip (2.7 MB)


#11

@pascal have you had any luck with this?


(Pascal Golay) #12

Hi Robin - we definitely see problems - there is a bug there, no question- but no fix yet either. I see the skp file you posted, I’ll have a try with that as well.

@robin - I’m afraid the ‘books’ skp file looks correct when opened here… I’m not sure how to track this one down - just out of curiosity, does mine look OK on your system? (Textures embedded, on skp open)
Books_PG.3dm (5.9 MB)

-Pascal


#16

hi @pascal @dan this problem is also occurring with materials we have set up ourselves. It is a big problem.


#17

@pascal @dan is there any update on this bug? It is continuing to cause us real problems. It just isn’t working the way it should.


#18

@pascal @dan is there really no update on this? Not even a big report?

Seriously, come on guys. First reported in November 2015, we are approaching two years and it hasn’t even been officially designated as a bug. What’s going on @robert


#19

@pascal @dan is there really no update on this? It’s rapidly approaching 2 years since it was first reported and not even mention of the bug being logged.

Come on guys! This is a serious bug.


(Nathan 'jesterKing' Letwory) #20

@robinp , in my own tests on Windows I get behavior as you reported, but models import correctly if I check the Use Sketchup Texture Writer. I don’t know if that exists on the Mac version, but if it foes, have you tried it?


#21

Hi, @nathanletwory yes I tried that. The problem occurs with user defined textures as well. There is a fundamental problem with rendering of textures in mac rhino and has been for 2 years


(Nathan 'jesterKing' Letwory) #22

@robinp I can’t help much with the Rhino Render part, and I can only offer a meager comfort, but this summer I’ll be working on getting RhinoCycles on the Mac WIP version. Your model renders fine with Cycles on Windows, it should work just the same on Mac.


#23

:scream:


#24

This is great news but won’t this require the RDK for mac rhino?


(Nathan 'jesterKing' Letwory) #25

Yes, it requires that.


#26

So do you have info about when the RDK is going to be available?


#27

Hello guys i was curious to look the file and test it with render and yes my render do same problem but i fix it with Blocks => Explode blocks after that command problem solved for me.