Rhino Pythonscript issues after upgrade to Win7 Enterprise

Hi All,

I hope you can help us with a problem we are having after our IT department decided to upgrade Windows 7 professional to enterprise (because they want to use encryption). After this upgrade, stuff got broken. Visual studio didn’t work any more and also Rhino Scripting fails to open. Rhino itself seems to start fine, but choosing Tools>PythonScript>Edit does not do anything. Trying to run a script (Tools>PythonScript>Run) generates the following dialog box:

Our Rhino version is:
Version 5 SR12 32-bit (5.12.50810.13095, 10/08/2015)

Is there anybody with an idea on how to fix this issue?

Thanks a lot!


Hi Peter - first make sure the IronPython plug in is present and enabled in Options > Plug-ins in Rhino. It might pay to simply reinstall…


Did you install IronPython on your computer (the one that is separate from anything Rhino)? Rhino may be accidentally picking that version instead of the one that ships with Rhino.

The IronPython plugin is present and enabled. We already tried reinstalling Rhino completely. We do have IronPython 2.7 installed separately on the same computer, but that has never been a problem before.

The separate IronPython 2.7 does work from the command line.

This error has also popped up when running the Run PythonScript.

Try uninstalling IronPython to see if that fixes things.

Ok, that worked…
We uninstalled IronPython and installed it again. Now everything works like normal again.

Thank you for the help!