Rhino planar mapping

Query.3dm (13.9 MB)
Hello All. I am trying to apply planar texture mapping of a sketch on the terrain (the sketch should follow the alignment of the rectangle curve (3D PROPOSED layer), But the texture is getting tiled all along the surface. I did the following procedure:
Panel-textures-add texture-bitmap mapping-select texture (sketch)-apply planar mapping-follow prompts.
Any help please. TIA

I’m not sure I understand your problem, but…

Have you checked the “No Repeat” in the mapping section as seen in the lower right. (Please excuse the custom colors)

Also, if you just needed this drawing for a guide that is a certain size, you can also use Picture command. Hint: you can use the Color Mask texture options, to knock out the background, too. All the white could go away, fairly well, leaving the black lines.

Hi Tika - - turn on the mapping widget (MappingWidget command) for the surface, and turn on control points for that - you can then manipulate the corner points so that the image matches the size of your terrain better.

Thank you so much. Yes it was the issue of clicking on no repeat and it did the trick. Best regards

Thanks Pascal