Dimensions are doing wierd things in Rhino 6... why?

Hi Mary, this issue is related to printing pdf’s also now, Please see the latest posting here: Rhino PDF not working! Help!

One more dimension related bug to report: dimensions are not adding up properly. See image below showing the overall dimensions with an incorrect 1/8" … and if this is a tolerance issue, then Rhino should round dimensions so this doesn’t happen (IMO).

Just to be sure, could you upload that file?

I’m pretty sure this is a tolerance issue, though, and this has come up once before but I can’t find the thread at this point.

Hello there all, I am having issues with getting the dimensions to work as I want them to work(like in rhino 5, nice and easy.) It seems I have adjusted every setting but my dimension keeps coming up 0". I have changed the scale , the size of the font, arrow, lines everything?
This has to get easier at some point. It would be great to go back to Rhino 5 dimensions or make them simpler and the sizes would scale automatically. Also the lay out of the dimension preference window is so annoying meaning I hate having to scroll with in a window within a window, what is the point there? It’s a bad design, I think when you select he dimension preference window it should pop up as big as it needs to be so you can see all of the options without scrolling down. It’s one idea anyway. Anyone have any suggestions? Thanks Dave

Hi Wim, I uploaded the file in this related thread: Rhino PDF not working! Help!

Hi Dpardoe,
I don’t think this “zero” dimension issue has been addressed.
However, it may be already handled and I missed it.
If it is still an problem, please email mary@mcneel.com a file that will show me this issue.

Thanks for your help.
Mary Ann FUgier

I exported everything to a new Rhino 6 default file and things were back to normal.


Hi ! I hope you’re successful working this out !

I solved the problem by dropping back to RH-5 for the time being. Where I need more sophisticated Shop and Production drawings than RHINO can provide, I dusted off a back-license of BricsCAD - an AutoCAD “workalike” that is SO MUCH like the real thing that I was BLOWN AWAY when I first got it, and at under 10% of the price of the real thing, I’ve found it to be HUGELY powerful (!) and DEAD SMOOTH. Associated dimensions work in Paper-Space layouts EXACTLY as you’d expect, and the reliability is just STUNNING ! While their implementation of 3D is EQUALLY impressive, I haven’t found ANYTHING that matches RHINO 3D in general functionality and BEAUTY , so I do my 3D there and my 2D in BricsCAD !

Their (BricsCAD’s) implementation of Paper-Space and Model Space is - up to this point - indistinguishable from the original (ACAD), and I’ve found this combination to be HUGELY powerful, breaking - for ME - the bonds of being tied to some mystery-macro ahead of the next “Commercial-beta” release of RH-6.

Check it out. There are other options on the market worth considering too, so I think you’ll find an EFFECTIVE solution, wherever you look. If you have no experience with AutoCAD, stick with RH-5 Drawings, they’ve done an admirable job in RH-5. Not having to produce and DELIVER shop-drawings in a genuine design environment with time, deadlines and budget constraints, RH’s team really can’t be faulted for a speed-bump or 2 as they make their way through this portion of their development process.

Not knowing first-hand what changes to make and how to prioritize Corrections, “Improvements” and New Features in an incremental/full-release operating environment has proven to be a real challenge for them, but they REALLY DO excellent work, and I fully expect good results soon ! Keep the faith, bud !

Ok, ALL the VERY best to you going forward, and post back with results ?

Thanks !

Chuck in Texas.

1 Like

Hi Peter!
I’ve had this one on my list and finally found that previous discussion - seems like we have crossed swords over this before :smile:

1 Like

Piping in, my alternate units should be scaling 6X and are not. This annotation style was originally created in R5. The weird multiplier is for a scale model reference. Tried changing alternate to Inches - Decimal but did not work. Also tried making a fresh annotation style but no dice.


Annotation settings below:

Hi Elijah,

That problem was reported above and the fix will go out in SR 6.9.

Thanks very much Alain

Guys, I’m having some trouble when opening a Rhino 4 or 5 archive in Rhino 6!
I’ve created a Layout, to Technical Drawings, in Rhino 4 and used it in Rhino 5, without any major problems, but when I open this Layout in Rhino 6, this (image below) happens… Any idea on how to solve this?

Hello - see if the settings here make a difference-


2 posts were split to a new topic: Dimensions disappear

Hello Pascal, thanks for the answer!

Yes, it made! The document I was having problems with is working now, with the Enable layout space scaling unselected.

There are some other documents that I was having some issues, I will try with them too


my dims are moving when I print to PDF, but oddly not when I print to the printer.

is there a known fix for this? Or am I being silly?


Hi - please run the Rhino SystemInfo command and post the result here. Also, please upload a simple sample 3dm file that shows the problem.

Hi @gileshg, what happens if you copy your whole drawing into a new empty file which is based on a default template included with the Rhino 6 install ? Does it still move the dims when you print to PDF ?