Rhino Option, ToolBar menu is missing

Hi, In my R6, when I select “Tools==>ToolBar Layout…”, I can’t find ToolBar menu under Rhino Option (before View). I can find it in R5 but not R6. Clicking “Restore Default” button doesn’t help.

Hello - please run SystemInfo in Rhino and post the results here.

-Pascal

Rhino 6 SR17 2019-8-23 (Rhino 6, 6.17.19235.15041, Git hash:master @ 06b69c5cc21d880aa793a5a7cfd454a66f6213bb)
License type: Not For Resale, build 2019-08-23
License details: Cloud Zoo. In use by: Ming Ma ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: LENOVOMING

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro M1000M (NVidia) Memory: 2GB, Driver date: 7-3-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.40

Secondary graphics devices.
Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 8-7-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-3-2019
Driver Version: 26.21.14.3140
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Workspaces\RhinoMAESTRO\RhinoMAESTRO\RhinoMAESTRO\bin\x64\Rhino6.Debug\RhinoMAESTRO.rhp “RhinoMAESTRO” 1.0.0.0
C:\Users\Ming\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\CreateQuadMesh (5bf6c0f3-3657-4ad5-834a-bbbb52706a40)\6.0.6950.16446\CreateQuadMesh.rhp “CreateQuadMesh” 6.0.6950.16446
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - Toolbars.rhp is present - can you look for it in Options > Plug-ins and see if it is enabled? If not, please check the box for Enabled, and restart Rhino…any better?

-Pascal

Hi, Pascal,
All checkboxes in Plug-in are checked. Restart R6 does not bring Toolbars menu back.
Thanks
Ming

Hi Ming - can you please try starting Rhino in safe mode?

Start Rhino in Safe Mode: Windows start menu, type in ‘Rhinoceros’ and look for the ‘Rhinoceros in Safe Mode’ entry.

If you are prompted to load toolbar.rhp, allow that but do not allow
RhinoMAESTRO.rhp

(this can also be disabled in the Plug-ins before closing and restarting)

Any different?

-Pascal

Hi, Pascal, After starting the safe mode once, everything works as expected. Thank you! Ming

Hm… Odd. but good! thanks for letting us know.

-Pascal