Rhino Layout Print Preferences Broken

Suddenly when I print to pdf from layouts my line weights are heavy. I have checked all linetypes and display modes and have tried scaling. The problem seems to be associated with page sizes suddenly being a different dimension than actual size. When I print to the A5 page with wrong dimensions line weight prints correctly. I have attempted reinstalling rhino but default layout print sizes remain incorrect.

Please help @John_Brock. 5 years using Rhino and this is my first topic lol.

Welcome to the forum. Can you post or send us the file? Rhino - Upload to Support

We’ll also need your SystemInfo (Rhino Command line)


systeminfo.txt (4.2 KB)

cactusclub_LOT.zip (3.7 MB)

Hi Matthew -

I’m having a hard time understanding what is being reported here.
Could you describe (1) what you do, (2) what you see, and (3) what you expect?
From your second screenshot, it looks like you are using the Print command to create a PDF?
On macOS, that command will use macOS code and is not something that we control. To create PDF files from Rhino on macOS, we recommend using the ExportAll command to make sure to use the RhinoPDF printer.

Hi @matthew_Stephenson ,

At larger page sizes use the size of “Hairline” for the Default Line Width in the Linetypes and Line Width settings after using the ExportAll command and choosing the PDF format. This will keep the dim lines from getting chunky.

I am an architect I am working in layouts and saving pdf to file from the layout panel. This has worked just fine for years. This is what this document was looking like all line weights correct:

Now when I go to print from layouts the architectural sheets size defaults are not accurate dimensionally so I created my own 24x36 sheet:

I have tried going through preferences but all of the linetypes are correct. I tried the suggestion below to change all default linetypes to hairline and that did not work. I reinstalled rhino and after everything I still get this:

Changed everything to hairline and still the same result

Did you try using ExportAll instead to make the PDF and changing to hairline there not as a layer property?

Hi Brian,
That did work. Thank you. Any clue as to why I could not do so via export from the layout print panel?

Yes, that is because the Print command which the layout panel accesses runs different code than the ExportAll command which allows you to use the RhinoPDF driver and edit the linetype and line width. I agree it is confusing and I will bring this up again with the developers. It’s a Mac specific PDF print issue. The take away is to use ExportAll to print PDFs on Mac.