Rhino keeps crashing whitout any save. A memory allocation failed and rhino will close


(Cam ) #1

rhino_issue
ENven after restarting, even turn off and on the computer, rhino wont work anay more. It let me do whatever I want, but as soon as I save, it crash giving me the erro in the picture.

On rhin its says that I have use 460MB and that there is still 13446MB free… so I dont undersand.

What could I do? It comes from RHino, not my computer as I have plenty of free memory.


#2

Hi Cam,

This could indicate a hardware failure, where some of your RAM might be damaged.

A quick google provides many options to check this.
https://www.google.nl/search?q=test+RAM+on+windows

Here is a not so complicated way to test it:

Please report back what you find

-Willem


(John Brock) #3

Do you have any third-party plug-ins installed?
If so, you might try disabling them to see if the crashing stops.


(Cam ) #4

Thank you very much @John_Brock and @Willem, sorry I couldn’t respond before. It is still crashing so I can not save any work, the only thing I can sve is the stl, but not .3dm files.

I checked and my computer is fine, thank you for the link. I think its Something about plug-in as it started this Strange behavior right after I accept to install a plug-in (as otherwise the first time when I clicked on no it did not download my stl. in rhino). I am still stuck, as I dont know any thing about plug in, which one it was etc.


(Nathan 'jesterKing' Letwory) #5

@cam If you paste the result of the Rhino command _SystemInfo here we’ll be able to tell you.


(Pascal Golay) #6

Hi Cam - start Rhino and in Options > Plug-ins, filter the view for ‘Plug-ins that do not ship with Rhino’ .
Disable these (probably only one or two) and try saving - if it works, re-enable one or two plug-ins at a time and try again until, hopefully, at some point it will crash and you’ll have an idea which plug-in is responsible…

-Pascal


(Cam ) #7

Thank you very much @nathanletwory and @pascal for your help!
When I use _SystemInfo command I obtain:

Rhino 6 SR6 2018-6-26 (Rhino 6, 6.6.18177.16151, Git hash:master @ abeff9e9af62a0e02a9eb52efa77e179a682f2c7)
Licence type: Évaluation, build 2018-06-26
License details: Cloud Zoo. In use by: Camille Montalcini ()
Expires on: 2018-07-30

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: LAPTOP-TJID61TE

GeForce GTX 1050 Ti/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.16)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-30-2017
Driver Version: 23.21.13.8816
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.6.18177.16151
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.6.18177.16151
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.6.18177.16151
C:\Program Files\Rhino 6\Plug-ins\RhinoResurf\RhinoResurf_r6.rhp “RhinoResurf”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.6.18177.16151
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

ALso when I check the plug-in in rhino as suggested, I have :

RhinoResurf is a plug-in which I neededseveral weeks ago, so it can not be this one.

Would you have any idea of which one I should delete (and how)? I was not able to find ‘‘Plug-ins that do not ship with Rhino’’…

Thank you very much for your help!!


(Pascal Golay) #8

Hi Cam - see Options > Plug-ins page

I would disable RhinoResurf and see if that makes a diffference.

-Pascal


(Cam ) #9

Hi @pascal!
Thank you for your answer, for now its working, but it seems to me that it can not come from this as I did not had any problem with rhino when downloading and during the next few weeks. Also, suddenly after accepting downloading a plusg-in I had the almost Always since the error, but I dont know which plug-in it was.

In any case thank you very much for all your help!!
Wishing you a nice evening

In any case