HELP Rhino 5 keeps crashing randomly

Hello to anyone who can help,

I’ve been experiencing this very annoying issue where Rhino 5 will randomly crash. Due to this I have set my auto-save time to 1 minute. However, I still feel that for such a high quality software and with a decent machine this shouldn’t be the norm.

Here are the specs of my machine:

Processor: Intel® Core™ i7-2630QM CPU @ 2.00GHz 2.00GHz
Installed memory (RAM): 64-bit Operating System, x64-based processor
Display Adapters: AMD Radeon HD 6700M Series and Intel® HD Graphics 3000

The only thing I have changed about this computer is installing a 1TB SSD about 3 months ago, but the crashing has been happening from well before that period.

Are there any configurations/settings that I may be able to optimize on my machine to reduce the crashing problem? Any advice would be greatly appreciated. Thanks for your time in advance!

*EDIT: I do not really utilize Rhino for intensive work, my file sizes are very normal, I used to really push the software when I was in an Architecture program at school, so that’s my frame of reference. The stuff I do now is child play compared to how I was trying to use the program in the past. So the crash is not happening due to virtual memory issues or to overload on the software.

-KE

A few things:
Do you have any plugins installed?
Does Rhino crash if you use it in Safe Mode?
Does Rhino generate crash reports that you send in to McNeel?

The most likely cause of this type of crashing is the GPU. Could you post a screen shot of the Rhino OpenGL settings?

No plugins
I have not tried it in Safe Mode yet
I dont remember if it sends reports to McNeel but I can look up that setting and turn it on (right?)

^ is this what you are looking for

May 2015 isn’t too bad but I would start with updating the driver for the card. That and running in Safe Mode or with accelerated hardware modes turned off.

As for turning on or off reporting of crashes, no, there is no setting for that - that should happen automatically.

Yeah, but it shows that this driver is updated to most current version. What are the trade-offs to running in Safe Mode or with accelerated hardware mode turned off? Also when you say safe mode, do you mean running my PC in safe mode, or is there a safe mode option for Rhino itself.

Thanks so much for your help btw.

Both safe mode and no acceleration are Rhino settings. Trade off is slower navigation and no aliasing of curves. How painful that is will depend on a number of factors. The point is that this is something that you can check quickly and find out if that makes the problem go away. It is not a solution but a diagnostic tool.

Hi Kareem- if you see a box pop up from McNeel, asking for details about what you were doing when the crash happened and a checkbox to include the crashed file with the report, please do fill out as much details as you can and send that in.
If you do not see that interface but you get some other error message frome Windows, please tells us exactly what the error message is.
Wim’s suggestions of running temporarily with hardware acceleration off is a good one, as well as trying Safe Mode. (no shaded viewports in Safe mode, it is only for testing.)
thanks,

-Pascal