Rhino Inside Revit: Cannot set revit element using the Element component

Hi all, I am trying to do a really simple step of selecting elements from Revit from Grasshopper using Rhino Inside Revit.

The problem is, the following Options are not showing when the Element component is right-clicked:

Instead, I only get this:

I tried both in my Revit 2018 & 2019 but got the same result. I don’t get the two options from the first image:
“Set one Revit Element” & “Set Multiple Revit Elements”.
Did I miss any step, did I choose the wrong component? Or do I have to reinstall, or use a different version??

Thank you so much for the help.

Regards,
Jazzy

Use the Geometry Element in the Params > Revit Toolbar:

image

1 Like

Hi Scott,

Yes. Figured that out eventually. I am currently starting with Grasshopper (previously doing Dynamo with Revit) and found there’s a lot of options in Grasshopper and most component’s name are completely different.

Is there some sort of a “Grasshopper Component Dictionary” listing all OOTB components and their description + samples?

Thanks!!

Here is a list of components: https://github.com/mcneel/rhino.inside-revit/blob/master/doc/gh-components.md

1 Like

Thanks, Scott. Btw, that link no longer exists but found the new one:

Also, I believe that the components listed there are only those in Rhino.Inside-Revit.
I was hoping to find a dictionary for the default components in Grasshopper for Rhino (without the other packages installed)

But thanks, anyways!

Jahzzy

That would be part of this list then: https://rhino.github.io/

1 Like

Ohhh. Finally!!

Yes, that’s what I am looking for!

Thank you so much!