Rhino Inside Adaptive Components not placing

I’ve been trying to get some adaptive components to be placed using Rhino Inside. Initially, I failed to place a set of 10 point families, so thought I’d go back to basics with a few 4 point families.

I get an error at the end in both cases telling me my indices are out of range. I’m confused as I watched the demo video (https://www.youtube.com/watch?v=etVbQGZ3myg) and it appears my list structure has been consistent with Scott’s approach. My understanding of trees vs lists isn’t great, so maybe I’m getting something wrong…

Just wanted to check if I’m making any mistakes, or if there might be an error in the node in latest build? I reinstalled WIP/RI this morning and am working in Revit 2020.2.1. I’m hosting a webinar on Rhino Inside in a week and would really like to get this to work to demonstrate its potential (and not just use direct shapes).

source files.zip (4.4 MB)

Was a bug.
It’s fixed, please update your copy from here.

Unfortunately it appears that it might still be present, or I’ve made a mistake somewhere in my code. I’ve reinstalled RI and Rhino WIP from the website just then and it is still giving me the same warning. I’ve also attached a basic 4 point example if that helps.

adaptive 4 point.zip (1.8 MB)

Your code is well done.
Could you please check you RiR version?

It should be from today.

1 Like

The definition worked as expected with the latest WIP & RIR

Revit Version

1 Like

Hrm you’re right it’s still the old build. I’ll do another reinstall - looks like it works at least so I know it’s on my side. Thanks everyone for the help, glad to know the code should work at least :slight_smile:



I think I have a simillar issue. Tried to nail down the exact issuse, so I simplified the case to the maximum.

  1. Created simple Generic Model Adaptive family (one point-based) called “Test.rfa”.
  2. Created a GH script to place it at 0,0,5 coordinates (internal Revit coordinates) - look at the screenshot.

The problem is:
I can manipulate the point coordinates with different values, but the objects always is placed at the 0,0,0 (doesn’t matter which values I give to the point).

I attach all the needed data to reproduce the issue.
Revit 2021.1.9

Do you have any ideas? I’m open to share more data if needed.

Thanks in advance,

Adaptive component placement.gh (5.1 KB)

Test.rfa (420 KB)

You are trying to place an Adaptive Component that has no placement points.

Add a placement point to your Family. See the guide below for the particulars of Adaptive Points.