Rhino - GH - Brep to Revit


I am struggeling again and again inserting geometry into a family created in GH inside Revit with the add form component. Direct shape kind of works but seems to mesh some parts and does not give the flexibility in Revit. A simliar definiton worked in march without problems.
The geometry is rather simple and works as workaround baked to rhino and then referenced back to GH and imported with add form. There are no edges of short curves or arcs, I tried to set the tolerances lower (0.001mm) but no success.
This is how it looks directly from GH:

This is the baked brep referenced back to GH:

Any ideas?

Hi Tom,

Could you please send me this geometry?
Or something more simple that fails if you prefer.


Hi Kike,

sorry for the delay but I just reproduced the error again. Here is the baked geometry which works fine with AddFrom when referenced back to GH as Brep and the same geometry as its nativly created in GH just internalised in the Brep component.

200703_SolidGH_AddForm_onlyParts_RhinoBrepsWork.gh (414.0 KB) 200703_SolidGH_AddForm_onlyParts_RhinoBrepsWork.3dm (3.8 MB)

Hey I just imported this in Revit 2020 and latest Rhino WIP and Rhino.Inside.Revit and it seems to be working. Try it with the latest of both Rhino WIP and Rhino.Inside.Revit and let us know:

1 Like


thanks for checking but I just installed the latest WIP and RH Inside version but still having the same issue using Revit 2020.2 this time with the GH file including the integrated data.
How did you do this?

The funny workaround in baking the geometry and referencing it back to GH for AddForm isn’t working anymore which is at least a consistent behaviour.

I tried these files and the geometry came in great from the 3DM file. But when I try and use the GH definitions there are errors.

The key difference is scale. The geometry in the 3dm file is in Meters. It is quite large (20 meters). The geometry in the Grasshopper definition happens to be in mm so the total depth is 20mm. Revit does not like edges less then 1mm. So, the smaller model has too much detail.

I expect the structure is supposed to be 20 meters? I would check the units that are being used in Rhino and Revit. Make sure they are the same when generating the geometry.

Does this help? I can answer any other questions about this if I am not being clear enough.

Hi Scott,

I see that baking the geometry from the GH file into a meter RH documents works when I refernce it back to GH for AddFrom.
But, the original definition is done in meters from were I internalized the data in the GH component. How does this can be milimeters or how could I check/change this if the RH document is in meters?
The position and scale is also right.
Did you manage to bring the internalized GH data to Revit?

Normally, I would Right-click on the input and then use the Extract Paramter. Then Right click on the extract parameter component and use Bake.

From my understanding, the units in GH are based on the unit settings in Rhino, so that baked geometry will always have the same number in lenght or whatever no matter what unit it is in.
I also came accross this old post from David Rutten about GH units:

What leaves me still puzzled is: Did you made the geometry from the Brep component appear right in Revit without baking it before to Rhino?

I think were the units can get messed up if the geomtry is internalized then the file units chagnge.

I used the 3DM file you sent that had the correct scale and then selected it into the Brep parameter.

I baked out from the internal definition just to see what that looked like.

OK this workaround was always working - I just had in my post from Aug 4 the RH units not set up right.
I also checked and recomputed the original GH definition which created the stucture with units in meters - no success. I don’t know what to do further, rebuild a copy of the GH definition?
Question is what is the baking doing - does it changes the geometry, rounding values to fit unit tolerances?
I am fine with the workaround but I would like to understand whats happening to avoid unconsistencies in furhter definitions.

Maybe I did not mention this before but an older version of the GH definition creating the geometry was working fine with Revit at the time. The version was created end of october last year and only since an update of RiR later on it appears to have this error…

I know there have been changes to how units work since then. But, it is working for you now if the larger model is used, correct?

Geometry can still be internalized that should work too. But the older internalized looks like it was on the wrong sure if a units change.

The direct creation of Revit geometry out of native GH components with AddForm is still not working. I just used internalized data to provide the result of a long GH definition I did not want to publish here.

Another trick, that we are working to document is that the Brep > Form component has to run inside a Family definition.

To get it to work, I create do New Family using a Generic Model Template. Then in the Open Family i recalculate the deifnintion. I get fine results:

Another way to do this in a Project, but then the Component Family Form component is needed instead. This allows a Brep to be wrapped up and sent to a New Family component, then inserted into the project.

The inconsistency we may be able to fix is the simple Add Form component, probably should also be able to feed into the New Component Family Geometry input in the same way the Component Family Form does. I will see if that is possible?

We released a version yesterday with a fix for this.

Please update.

Hi Kike
hi Scott,

I don’t know what you have changed but I updated Rhino WIP and RIR and it works!!!
Perfect! I hope this stays like this :slight_smile:

Thanks a lot for the effort!