Missing Brep while creating a new family through rhino

Hi folks,

I’m trying to create a Revit furniture family through rhino.inside and grasshopper.
I modeled all closed polysurfaces, but when I run the definition, I can see just one element of the whole geometry.
I tried also with another shape some days ago and had similar problems that I solved by redoing the model with different geometries.

Is this some known issue or am I doing smth wrong?
Is there a way to check if a Brep is valid to be imported into Revit? It looks like working just with very simple geometries.
And last: is there a different way to apply materials directly into revit to a whole brep imported from rhino and associate a material parameter? Direct shape is not a solution because you have to apply the material from rhino.

Here what I modeled into Rhino:

Here what I obtain into Revit:

We are constantly improving the routines that convert geometry from Rhino to Revit and the other way around, so please update to the latest version.

Anyway, could you please share this Rhino Geometry?
I will take a look to it and tell you why it fails.

On the family types parameters question, we currently do not have any component to do so.
What I can tell you is that it is on the list https://github.com/mcneel/rhino.inside-revit/issues/108

Thank you @kike , attached you can find the model.
About family types, you will know that if you succesfully import a Brep, you will get a “native” Revit geometry, and you will be able to apply a material parameter.
Also if you import a 3dm you can apply materials through “Imported Objects” tab.
It would be nice to have a similar workaround also for rhino.inside (waiting for a further update)

Shangai_model.3dm (4.2 MB)

I updated the Rhino.inside Revit version and tried to simplify the geometries:
Two notes:

  1. If I remove the top of each stick I can import the rest of the geometry into Revit:

  2. Maintaining the original shape I have an improvement of the imported geometry in any case: I can see also bolts now:

I tried to simplify at the maximum level the geometry, and it looks like it doesn’t like shape number 1:


It seams that Revit doesn’t like degree 2 curves.
Edges of blue surfaces are degree 2, approximating an arc.

Now we convert those curves to degree 3 curves with same shape and works.


This should be fixed in the version from today.
Please update from here.

1 Like

I’m adding to the thread here since it aligns with the issue I am facing. I’m having trouble transferring rhino polysurfaces into the “create family form” component. I’ve tried rebuilding them several times and still no luck. What I found weird was that it manages to translate properly as a Directshape Brep.

Any thoughts @kike? Images attached.

Scott has a great post here explaining the underlying issues and suggeting a few tests to make sure the geometry is prepped for Revit

1 Like

Hi Ehsan,

Yes, I also discovered where the issue was. Even in a closed polyline, if there are segments or curves that are <1mm, any subsequent geometry built from the profile would not be created in Revit.

Thanks again.

1 Like