Rhino Fillet and Grasshopper fillet not related

Hey everybody
I seem to be facing a weird bug in GH (But most probably I am missing something) with the fillet component. The results given by grasshopper and Rhino when filleting a planar polyline are not consistent:

Red: GH fillet, Purple: Rhino fillet and input curve

The only way to get the same result in grasshopper is to extend the polyline in both directions, reduce it and filet it. The surprising thing is that rhino finds a good result (and other CAD software as well) but GH is not able to go over some threshold radius even though it is geometrically correct.

Does anybody have some inputs about that?

Hi Ceillier,

I got similar problem. The different thing is: all my geometries are in GH, after created fillet with same radius, the output fillets are not identical. Wired thing. seek for solution.


Can’t say why this happens, but what I ended up doing some time ago was creating a circle. Calculated the intersection, splitted the line and circle and merged them together. Maybe not the fastest solution for calculation time, but in a hurry the only way I could imagine.

One thing i am thinking could be you problem is the number of control points of your polylines before filleting them, have you tried “reduce” before filetting?

Thanks for your answer, i found a workaround too in my case (extending the lines, then exploding to get the arcs and rebuilding the straight parts from the arcs) but i am still wondering what can be the origin of this behavior

Both GH Fillet components are impredictable.
I use c# component with :

private void RunScript(Curve C, double R, ref object FC)
FC = Curve.CreateFilletCornersCurve(C, R, 0.01, 100);

You can add inputs for tolerance (0.01) and angle tolerance(100).


1 Like