Bug Report:FilletCorner Component

Maybe it is a bug:
1.When the radius is 5, the component work well;
2.When the radius is 10, the component work well;
3.When the radius is 10, Without using Gh,Rhino work well.
See picture or gh file below.

Bug Report of FilletCorner Component.gh (56.0 KB)

just for info, by reparametrizing the input curve the fillet works correctly

Sorry but i cant repeat your solution .
I notice that once the finial arc was over any control point of the original curve ,GH component would fail ,as well as Rhino would done well . See picture below.
So I think it probably is of bug .

In that curve there is the only curvature discontinuity of all your curves, and for some reason the fillet fails.
I suggest you to shatter your curves using tangency discontinuity parameters, rebuild them to cleaner curves, rejoin them … and then I’d expect fillet to work fine.

Thanks for your answer is really helpful and inspiring. It seems that the tangancy- discontinuity point cause the problem, once it’s one curvature-discontinuity point there would be no problem. However, rhino can handle the tangancy discontinuity , so hope gh could do the same things one day .

one thing I forgot to mention… I’m on V 8.0.23304.9001, 2023-10-31 :thinking:

With your help, I tried to change the tangancy-discontinuity point into curvature discontinuity and succeeded.
For the curve is based on one extended method, i just change the extension type from line to smooth. through problem was solved ,I still insist it’s a bug ,Gh could have done as good as rhino can .
extend curve smooth

1 Like

The problem was solved.
I still insist that it is a bug ,because rhino could done better.
I hope the next version of gh could do this work as good as rhino.

I’m not so sure what’s going on here. This fails with both tangency continuous and curvature continuous curves.
On the list… → RH-78249 Grasshopper: Fillet - Failure cases