Rhino Eating my Hard Drive Space

Rhino appears to be eating my hard drive space.
While working in Rhino my hard drive capacity is eaten up by “other” at a rate of about 13 to 14GB a day for an average day of about 10 working hours. Once the 2.12TB drive is full the only recovery option is to reinstall the entire drive (system and files) from a backup. This takes about 20 hours and then leaves me with 1.7TB of free space which rapidly starts to fill up again as soon as I open a model and start working.

I have reported this on an Apple support thread, discussed it with an Apple support technician, tried to analyze my drive using Omni disk sweeper, etre check and other software, all to no avail.
There doesn’t appear to be any way to analyze what compromises the other. Could it be backup files generated by Rhino? I’m not using any other memory intensive software.

I have been using Rhino for Mac for a number of years and this issue only seemed to crop up in recent months.

Rhino Version 6 (6.27.20176.04592, 12020-06-24)
Mac OS10.15.5

Please run the Rhino “SystemInfo” command and post the results.
This will give us a good overview of how your Rhino is setup.

What commands are you typically running?
Have you noticed any association between drive space being used up and which commands you’re running?

Rhino 6 SR27 2020-6-24 (Public Build, 6.27.20176.04592, Git hash:master @ ba2c30de00be5a8b210bc297715204e941911799)
License type: Commercial, build 2020-06-24
License details: Cloud Zoo. In use by: Tony Grainger ()

Apple Intel 64-bit macOS Version 10.15.5 (Build 19F96) (Physical RAM: 32Gb)
Mac Model Identifier: iMac18,3
Machine name: Tony’s iMac
Language: en-TH (MacOS default)

AMD Radeon Pro 580 OpenGL Engine (OpenGL ver:4.1 ATI-3.9.15)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB
Graphics: Radeon Pro 580
Displays: iMac (217dpi 2x)

Graphics processors
Radeon Pro 580 (8 GB)
iMac (2560 x 1440)

USB devices
Western Digital: My Passport 25E2
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Magic Keyboard with Numeric Keypad

Bluetooth devices
Broadcom: Magic Mouse 2

Third party kernel extensions

Third party plugins

Rhino plugins
/Applications/Rhinoceros 2.app/Contents/PlugIns/RhinoRender.rhp “Rhino Render” 6.27.20176.1002
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 6.27.20176.1002
/Applications/Rhinoceros 2.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 6.27.20176.1002
/Applications/Rhinoceros 2.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 6.27.20176.1002
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 6.27.20176.4592
/Applications/Rhinoceros 2.app/Contents/PlugIns/SolidTools.rhp “SolidTools” 6.27.20176.1002
/Applications/Rhinoceros 2.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 6.27.20176.1002
/Applications/Rhinoceros 2.app/Contents/PlugIns/RhinoBonusTools.rhp “Rhino Bonus Tools” 6.27.20176.1002
/Applications/Rhinoceros 2.app/Contents/PlugIns/Displacement.rhp “Displacement” 6.27.20176.1002
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 6.27.20176.4592
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 6.27.20176.4592
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 6.27.20176.4592
/Applications/Rhinoceros 2.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 6.27.20176.4592

130720 497.6 ±5:00 Wi fi on
499.76 @05:29 Rhino, WiFi off
501.33 @06:16 Rhino WiFi off Stop work
501.89 @07:13 WiFi off Start work
505.86 @08:17 Working Rhino
508.91 @09:53 Working Rhino Quit Parallels
511.32 @12:32
531.66 @21:22 Close Down Rhino +34GB

140720 510.25 @05:24
Work is mostly surface building and 2D drafting on complex models up to 2GB. No rendering for last two days.

Work log for last two days:

510.27 @05:58		Open Rhino but not open design
		510.27 @06:53		Open design but not working
		510.25 @08:09		Open Design and start work
		513.76 @08:45		Working
		519.75 @12:38		Working
		533.22 @19:36		Finish for Day +23GB Leave model open;.

Log of increasing other for 15th July 2020. Rhino was only software used all day except for a couple of brief visits to text doc’s. Work was all 2D drafting.
150720 531.31 @04:17 Start Working 2D Drafting
540.25 @09:22 2D Drafting
548.87 @13:58 2D Drafting
552.42 @15:58 2D Drafting
557.62 @17:20 Finish for day +26.31GB on drive as other

After 3 hours of modeling- mostly surface building and trimming - Other continues to increase at just over 2GB/hour - similar to drafting work.

No answers, only that after reading your post I checked to see that I have a much milder case [of possibly the same issue] with about 150GB taken by Other out of a 500 gb SD… and that swale-up likely have accumulated for about 1 year [since last clean install]
Two diferences in usage:

  1. don’t actively use Rhino for so many hours a day
  2. I never used V6, Only 7WIP

One question [Perhaps you already check that…?] Would be, where does rhino keep all the versions? Is it in the file itself? or maybe in the Other container…?
And then how often do you press Cmd+S when you work…?
[that creates a new version, and that should add up on the disk somewhere AFAIK.

I hope you find the solution.


Hi Akash- I dont know where Rhino keeps the versions because there is no way to access the Other - even using software like Omni Disk Sweeper and Find All Files - but I assume it is part of Other. This is a major problem with Apple’s OSX as can be witnessed by the number of users looking for solutions to increasing Other on online forums. My posts on the Apple support forums and phone consultation with an Apple consultant have produced no useful information.
I very rarely use Cmd+S - most of the time never use it.
It would be interesting if you could check your hourly increase in Other while you are using Rhino. For me it is a bit over 2GB every hour.

Sure I will take notes of the Other numbers per hour

[when you have an urgent problem it is often best to tag a Dev. ]

I would think @dan from Mcneel Dev. knows if the versions go into Other. and perhaps what can be done about it.
He’s the one originally posting explanations on Rhino Mac saving behaviour [AFAIR]


Hi @tgra
So I took down the numbers for [probably less than] 1 hour active Rhino work.
It went up from 139.5gb to 139.95gb. but then I quit rhino and said yes to keep changes and then it jumped to 155.32gb !
so 15 gb for 1 hour session.

But it has to also go the other way [releasing space ] as if that was not the case I would be long since out of disc space.
a user guess would be that your system somehow does not release anything, so it accumulate so much. While here it seems to release most of it but not enough to avoid a slower accumulation.

I hope this can be fixed


It is very possible that Rhino is implicated here. That said, we do not know of any bug per se (not one we can reproduce as of yet) that is causing it to unduly eat up excessive disk space. Rhino uses macOS’s Versions feature and large files that are saved frequently can start to eat up a lot of space. It is unfortunate that macOS no longer allows you to disable Versions (previously it was possible) for those of you who dislike the feature; some people love it.

There are number of recommendations here:

that may be useful. I would point you toward the “Can I delete old versions of the file?” section as that may free up space. I would also repeat the recommendation of DaisyDisk to get a sense of where the actual problem lies.

1 Like

Hi DAn
thanks for looking into this.
DaisyDisk is very impressive, Studying it now, thanks for the link.
It is not immediately clear how to look into the Other, it doesn’t show it, as far as I can figure it out [also after granting full disk access]. I still have this grey 155Gb of which 15 were added on the last Rhino save. meaning I checked before saving, saved the file quite rhino and checked agin. Nothing else happened during that 2 minutes interval. So it has to be Rhino.
[the file in question is mid size about 350mb]
I now run Time Machine Backup, and checked the volume, and it hasn’t remove anything from Other

Edit : missed the recommendation not to buy daisy from the App Store… maybe this is why Other is not accessible.

thanks a lot

DaisyDisk [the non App Store version] scanning as admin
it only sees 333GB out of the 500GB Sd. So it does not see the Other container.

any ideas?

thanks a lot

I have provided the Apple technician (in Tasmania) who initially looked into this for me with a link to this thread and suggested it needs to be addressed by someone in Cupertino. Maybe someone at Rhino (Dan?) could do the same if not already attended to?

Another test I did just now
went in File> browse all versions
and it opened that version UI, but after spinning for over 10 minutes, it was not able to load the version and eventually rhino gave up.
@tgra would you like to try this to see if the versions become available [as they should] for one of your large quick filling files.

the idea is to see if deleting old versions actually clear some of space in Other

IMO the whole Mac file system sucks, especially when working with files on cloud drives. But also local, the many times I was making an alteration to a file that I later wanted to save as… are countless, since I work on both Mac and windows I often forget this doesn’t exist. Also it’s really cumbersome that there is not really an option to not save a file when working with files on OneDrive I noticed.

Anyhow, I was thinking of another option that might work: save a new version of your file and delete the original, does that free up space maybe by deleting the file with all its versions?

1 Like

And yes indeed that potential nice feature has never worked for me either. Just keeps spinning and it’s not clear what is what

I went to File: revert to, and it told me no previous versions available. However Other increased overnight by more than 15GB. I have been happily using Time Machine for some years and would love to be able to disable versions. I have never used it in the past and it appears to duplicate what Time Machine does and simply add a lot of complication.
160720 553.45 @04:35 Rhino Model open but not working
553.04 @09:57 Rhino Model open but not working
554.79 @14:00 Some Draughting in Rhino

	         556.60 @15:00		Finish 2D work - Start Modeling and Rendering
		560.73 @17:05		Building and Trimming Surfaces 2 hours

170720 576.6 @05:17 Start Work

thanks for the idea.
I tried that just now, and then did a system restart. But it didn’t remove anything from the OTHER container.

  • I also use Zbrush that quickly creates hug files and backups [because it save undos with the projects] but it all goes [the old way] into regular folders, making that system easy available for cleaning.

@tgra. thanks I’m out of ideas. I hope @dan and others at Mcneel team will be able to figure this out.

With best regards

Save As does exist. Hold down the alt/option key and then click on the File menu.

1 Like