Rhino doesn't open dwg anymore

As far as I can tell, we are still trying to determine what the problem is.
Do I understand it right that you are exporting from AutoCAD?
Are these objects in paper space or model space?
Can you share a simple file that is not getting read by Rhino?

all the objects are in model space. file attachedXVF - 0120.dwg (456.3 KB)

The file is too new for file reading libraries in Rhino V5.
Have the originator save a 2012 file, or you can open it in the V6 WIP.

I saved it as a 2000 file and was able to open in R5 Win, save it as a 3DS then open in R5 Mac. But not able to open the 2000 direclty in R5 Mac. I just downloaded a Mac evaluation license, but is there a fix or workaround? I’d like switch over to just the Mac license but I typically get all my arch and eng files as ACad. File attached.XVF - 0120_2000LT.dwg (703.8 KB)

I just now opened that XVF .DWG file in Rhino for Mac 5.5.2 without any issues:

Hi, trying everything under the sun to get a .dwg and .dxf file from AutoCAD 2018 Mac into Rhino 5.5.4 Mac. Keep getting error messages. When the file is converted to PDF I can get the vectors but nothing else, and scale is off.

Have tried myriad of versions and checked my settings in Rhino.

Here is the file;
Jon test.dwg (69.3 KB)

I am also unable to open the file provided by David12 above, same error messages

And I can’t open the file XVF - 0120 2000LT.dwg either

Correct. The DWG format is too new for the tools in 5.5.4.
It opens in V6 Mac and Windows just fine.

1 Like

Correct. Tested that.