Cant open/import Autocad files!

unhandled
autocad

(Simon Mouritsen) #1

Hi Rhino for Mac folks

I have the latest Rhino for Mac running 5.5.2 and the latest Autocad Mac.

I have a few Autocad files I want to import into Rhino to make a 3d model.
But then I import any Autocad files DWG and DXF it comes up with an error.

File has errors – Attempting recovery.

Some objects may be changed or deleted.
Read commandline messages to see recovery results.

and

Opendesign error : Invalid file version

Can’t recover file.

Does anyone know how to fix this problem? I know I’m not the only one with this problem. I have tried to the Autocad file in all the available file formats.

Rhino please fix this problem


(John Brock) #2

Try exporting from AutoCad as an earlier DWG/DXF file format.
Any luck?


(Simon Mouritsen) #3

I have tried them all. DWG/DXF 2018/2013/2010/2007/2004/2000/R14/R12. None of the works.

I have read other topic with the same issue and there is no solution to the problem.


(Eeva197) #4

Unfortunately im having the same issue - I did read somewhere that it is about the APFS system that comes with high sierra - HFS / NTFs was on the older systems. I think at some point this nee APFS interferes with it. ;{{ I need a solution quick HELP!!!


(Simon Mouritsen) #5

Bummer!

Rhino and Bob Mcneel please fix this problem fast.


#6

From @eeva197’s post, sounds like this might be an Apple problem…


(Simon Mouritsen) #7

I did a little research on the new system. It seem like a deliberate decision to change to a new system in order to have OSX and iOS run the same system. I don’t think apple will do anything about.