5.2.2-4 destroys dwg files if cancelled while opening - Fixed in 5.3


#1

Importing dwg files causes Acad Import Error and destroys original dwg file accidentaly.

Original and destroyed files are in the archive.
acad-import-bug-example.zip (5.3 MB)


(Dan Belcher) #2

Hi @epiphany-

Thanks for providing the files! (Sorry for the delayed response).

I tried to reproduce this issue today (again!) in Rhino 5.2.3 and I was unable to do so (Retina MacBook Pro, macOS Sierra 10.12). Here are the steps I took to reproduce what you are reporting:

  1. Launched Rhino for Mac (5.2.3).
  2. Started a new modeling window.
  3. Ran the _Import command.
  4. Navigated to the file you provided FILE-ORIGINAL.dwg.
  5. Accepted the default Open AutoCAD file settingsā€¦
  6. Clicked Open.
  7. Waited about 2 minutes as it cranked.

Here is the result that I receivedā€¦

Command: Import
Opened AutoCAD file version AutoCAD 2000.
--
Model space objects read: 8310, skipped: 27
Paper space objects read: 0, skipped: 0
Block definition objects read: 181010, skipped: 1
XRef objects read: 0, skipped: 0
File "/Users/dan/Desktop/acad-import-bug-example/FILE-ORIGINAL.dwg" successfully read
File "/Users/dan/Desktop/acad-import-bug-example/FILE-ORIGINAL.dwg" imported successfully.

and the file is fine (well, no changes to FILE-ORIGINAL.dwg at all, which is what I would expect).

Can you please help me better understand how you managed to create FILE-DESTROYED.dwg? What additional steps do I need to take or which steps am I missing?

Thanks,
-Dan


#3

Could it be related to dropbox sync? Iā€™ve opened dwg file via Open cmd+O or via doubleclick dwg file associated with the rhino.app - dropbox sync was active all the time


#4

Hi, I was having trouble importing DWG files too and was able to replicate the problem on Rhino for Mac 5.2.3, on a Late 2013 Retina MacBook Pro, macOS Sierra 10.12, on a new Rhino window.

Running the Import command and selecting the file produces an error before the Open AutoCAD settings box comes up. In addition, trying to open the file by dragging and dropping destroys it (attached), even though when the dialog box pops up to ask if I want to save, I select the ā€œRevert Changesā€ option.

I have imported and worked with DWGs successfully in the past, so I suspect it might have something to do with this new version of Rhino.

FILE-ORIGINAL.dwg (34.5 KB)


(Mary Ann Fugier) #5

Hi Seeyf,
When import DWG/DXF, the file must be a valid form of these files types.
I tested this file by importing into AutoCAD 2017.
If AutoCAD can not import its own file type, Rhino certainly will not be able to.

This file failed. AutoCAD is unable to open it. AutoCAD reports "file is not invalid."
What application created this file?

Sorry for the bad news about your file.
Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA


#6

Hi Mary, initially AutoCAD was able to open the file, but after trying to open it with Rhino, the file was corrupted by Rhino into that version I uploaded in my previous post and became unable to be opened as you described.

However, I havenā€™t had any problems with DWG files since that day so it might have just been something going wrong on that day. You can regard this issue as closed, thanks!


(Mary Ann Fugier) #7

Thanks for the update, Seeyf.

Rhino should not be corrupting a file that it does not read and then write to a 3DM or other format.
So I am hoping this is not the sign of something more sinister going wrong, like a hard drive or controller going bad.

Let us know if the issue ever returns.

Sincerely,
Mary Fugier


#8

@dan @mary
confirmed in version 5.2.4
steps to reproduce:
open dwg - in import dialog hit Cancel - close the window WITHOUT SAVING (revert changes) - another Import dialog appears /huh, strange!/ - again hit Cancel - Now original dwg file has 31kb and is completely destroyed.destroyed.dwg (30.4 KB)
original.dwg (11.6 MB)


(Pascal Golay) #9

So far, Iā€™m getting errors opening the freshly downloaded ā€˜originalā€™ to begin with - it just hangs and spins the beachballā€¦ On both Windows, v5 and V6, and Mac, btw. OK, 6 took a while but opened the fileā€¦
Rhino for mac eventually opened the file as well. OK, onward, to test the destroying part.

-Pascal


(John Brock) #10

@dan @marlin

I can repeat this in 5.2.4, but not in the current WIP.


#11

@pascal keep waiting few minutes, but this is not related to file destroying.


(Mary Ann Fugier) #12

Hi Epiphany,
Thank you so much for sending the files and steps. It was very helpful.
We are able to repeat the behavior you report with the Rhino for Mac 5.2.2 & 5.2.4.

Interestingly, we can not repeat the file corruption with the same steps in the current Rhino for Mac WIP.
Would you mind testing this in in the WIP for us?
We feel this may already be fixed, but would appreciate your input.

Thanks again for your help.
Sincerely,
Mary Fugier


#13

Hi Marry - confirmed - dwg destroying issue seems to be fixed in the latest WIP. Thanks.

One more thing in the latest WIP: