Rhino doesn´t import ai or dwg files on new OSX Maverick (Wenatchee 2013-10-28)


#1

My Rhino doesn´t import .ai and .dwg files. I tried to import a file but rhino showed me a grey background and a text: “loading”. nothing else happened.

a friend of mine got the same problem.

here is my OpenGL setting:

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2013-10-28 (486)
OS X version: Version 10.9 (Build 13A603)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro5,1
Processor: Intel Core2 Duo CPU P8600 @ 2.40GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce 9400M OpenGL Engine
Memory: (null)
Screen size: 1680 x 1050, 1440 x 900
Displays: Acer X223W, Color LCD

USB devices
None

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.18.27 310.40.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

Best,

Mazze


(Marlin Prowell) #2

I am not able to reproduce this behavior on OS X Mavericks, but I am not testing with the exact same conditions.

Please zip your model(s) and send them to mactech@mcneel.com. I’ll be able to test this tomorrow (Thursday) on a MacBook Pro that is about the same age as yours.

Perhaps by more closely duplicating the conditions I might see this.

Also post your friend’s OpenGL settings. That might also provide a clue.


#3

hi marlin,

it doesn´t matter which model i use. i also tried it with a new file and also with different files to import.

my friend´s setting is:

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2013-10-28 (486)
OS X version: Version 10.9 (Build 13A603)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: MacBookPro4,1
Processor: Intel Core2 Duo CPU T9300 @ 2.50GHz
Memory: 4 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce 8600M GT OpenGL Engine
Memory: (null)
Screen size: 1440 x 900, 1280 x 1024
Displays: Color LCD, SyncMaster

USB devices
None

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.18.27 310.40.05f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None

thank you


(Marlin Prowell) #4

I have exactly the same computer as your friend that I use for testing. Importing dwg files works fine on that computer running Mavericks.

However, I do not have an external monitor on that computer. Please have your friend unplug his/her external monitor and try again.

I ask again: please send me model(s) that fail. I am trying to eliminate as many differences as possible when trying to duplicate your problem. If you don’t send me models that fail, I will not be able to find the problem.

Lastly, have your friend restart that Mac in Safe Mode. Starting in Safe Mode takes a while, but it keeps any third party extensions and drivers from loading. This is a further attempt to eliminate any differences between what you are testing and what I am testing. I started my MacBookPro4,1 in Safe Mode and was able to import DWG files.

When Rhino imports a DWG file, it reads the file first, and then shows a dialog asking various options of how to convert the DWG file to a Rhino file. Does Rhino show you this dialog and then hang, or does it hang before ever showing the import options dialog?


(Pascal Golay) #5

This works here as well- Mavericks and latest Rhino.

-Pascal


#6

rhino pops up a window but for a very very short time. i can´t really see what kind of window it is but i think that’s the window you are talking about.


(Marlin Prowell) #7

Try the 2013-10-31 WIP release and see if it fixes this.


#8

nice, it works!!!
thank you.