Rhino display not updating after commands

In the last two days I have run into an issue where the viewport/display won’t update/change after selecting or running a command until after i rotate the view.

A couple examples
1 I select an object. it appears nothing happens until I rotate then the object shows that it has been selected.

2 - run the mesh command, the command lines says it created the mesh but the mesh is not visible until after I rotate the viewport.

3 - even a simple move command, the object does not appear moved until after I rotate the view.

Oddly I used Rhino this past weekend and it worked fine.
I did try to update my display drives to see if that would fix it but it did not.

I do not recall if there were any windows update since the last time I used it when it did work fine.

I’m running Rhino 4 (yes its old but I only use it for hobby stuff now)
Windows 11

Any thoughts on what it could be?

There have been some recent Windows 11 updates. It may have broken something for V4, I don’t have it installed here. What are your video card specifications? Are the drivers updated?

@Helvetosaur here is what rhino 4 options says about my video card

Updating the driver was the first thing I tried and had no effect.

I did try uninstalling and re-installing Rhino also and that did not work.

if it was a windows update, I’m guessing it will be rather difficult to find exactly what it is and how to fix it.

I’m wondering if a system restore would do the trick. just to see if it was a windows update.

So I looked at a few options for openGL in Rhino.
I found that unchecking the “use accelerated hardware modes” so far has done the trick.
seems to be working.


1 Like

That basically means you are no longer using your graphics card at all…