Can't rotate viewport when objects are selected

My biggest gripe lately with Rhino8 is that for some reason when something has been selected, I can’t use the mouse to move or rotate the display until I’ve deselected the thing. Kind of maddening. Don’t know if there is already a report about this. It doesn’t matter what project. Here’s my sysinfo
Rhino 8 SR6 2024-3-26 (Rhino 8, 8.6.24086.11001, Git hash:master @ 8e3b686f596bb6443e56e6dbecf0f54f4888713a)
License type: Commercial, build 2024-03-26
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 8GB)
.NET 7.0.12

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 1-20-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P600 (NVidia) Memory: 4GB, Driver date: 11-1-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 537.77
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-1-2023
Driver Version: 31.0.15.3777
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24086.11001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Hmm, first try updating your video drivers…

2 Likes

Grrr! My video drivers are as up to date as I can get them via Dell. I don’t think it’s video drivers. This doesn’t happen 100% of the time.

Don’t get them from Dell. Get them directly from NVidia and Intel.

1 Like

The problem I have reported is not a problem on Rhino 7.

Hi @Joe4 so far I haven’t seen any other report of this happening in Rhino 8 and this really smells like a driver issue.

It could help to download drivers from NVidia as Mitch said, and perform a clean install of the drivers.

1 Like

I did have this as well but I was also running a grasshopper and a script editor instance at the same time handling some selection logic.

If I can repeat again I’ll post back with what triggered it.

Most recent P600 driver at this time: NVIDIA RTX / Quadro Desktop and Notebook Driver Release 550 | R550 U4 (551.86) | Windows 10 64-bit, Windows 11 | NVIDIA

Of course it needs to be repeatable without third party code running first.

1 Like

I went to NVIDIA and updated to the latest, then went to Intel and update to what they said was the latest. I don’t seem to be able to make Rhino happy. I still got notification as follows.
image
Here’s sysinfo
Rhino 8 SR6 2024-4-2 (Rhino 8, 8.6.24093.11001, Git hash:master @ de3127ef7b7fd6e4c2fef07a9a1bc10c8e1942a3)
License type: Commercial, build 2024-04-02
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 8GB)
.NET 7.0.12

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 11-13-2023 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P600 (NVidia) Memory: 4GB, Driver date: 3-14-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 538.49
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-14-2024
Driver Version: 31.0.15.3849
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.6.24093.11001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Rotation still a problem after selecting objects?

1 Like

Those notifications are bogus… Does the rotation problem still occur?

Did you perform a clean install?

Hi Joe - so, if you start a new model and make a box, select it and try to manipulate the view with the mouse, you cannot, is that correct?

Does RotateView or Pan or Zoom work from the command line or from the default buttons?

If so, do you have a different mouse you can try?

-Pascal

Hi Pascal,
What you describe is correct. But it is an intermittent problem. It may happen only once or twice per drawing session. So I’ll have to try using the command line next time and try to observe if there is anything that led up to it.
I had not reported this before because it was so intermittent. It’s maddening when it does. When I saw the thread in the summary with the litany of other problems, mine sounded a little like the one where the command line loses focus which I have also experienced. So I threw my 2 cents in. We can probably close this thread now and let me try to reproduce it and gather more information.
Thanks,
Joe

I presume you’re describing an old issue that got worse in version 5, and has never been corrected ever since.

I don’t believe it’s directly related to ‘objects having been selected’. I do believe it mostly has to do with various command function activations, completions, dialogues etc.

My usual ‘hurdle over the problem’ is to quickly click with the regular mouse into an empty spot in the workspace, in order to correct the glitch.

Sometimes you might even have to invoke a regular rotation with the regular mouse to correct the glitch.

This used to be very frustrating to perform every time to mitigate the issue, but things like this can become subconscious after you do it a million times :sweat_smile:

It would be great if the world we live in would finally accept the 3D mouses, but they’re still waiting for something …

Not sure my issue is the same. I haven’t run into it until Rhino8 as far as I can remember, and I’m just using a regular Logitech mouse. I think I’ve only seen it when something is selected which makes it especially maddening after spending some time selecting just the right thing, or things. But I am going to take care to log future occurrences and try to define the conditions.
Thanks…