Rhino 6 keeps crashing

Dear all,

Since I uploaded windows 10 rhino 6 has been a bit of a nuisance. It seems that every time I turn off the laptop then Rhino 6 plays up - the programme keeps “not responding”. Usually running the repair fixes it and it works fine. However I have spent three hours this morning trying to get it to run properly. It just crashes and runs slowly now.

Can anyone help please?

What’s happening exactly? “Not responding” doesn’t mean it’s crashed necessarily.

Run SystemInfo and post the results here.

Bizzarely I ran the repair five times and swore a lot at the laptop which seems to have fixed it. I think the threat of violence has helped.

System Info

Rhino 6 SR24 2020-3-19 (Rhino 6, 6.24.20079.23341, Git hash:master @ 064283610b834170e52117f2656605b5b25d65c0)
License type: Commercial, build 2020-03-19
License details: Cloud Zoo. In use by: Laurence Dowson ()

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)
Machine name: SSL-LAPTOP0308

Non-hybrid graphics.
Primary display and OpenGL: Intel® HD Graphics 4000 (Intel) Memory: 2GB, Driver date: 7-10-2015 (M-D-Y). OpenGL Ver: 4.0.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build
Driver Date: 7-10-2015
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2112 MB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.24.20079.23341
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Your video driver is over 4 years old, so finding an update for that would be a good start.

Thank you - so it was not the threat of violence then!!

100% your video card driver. Intel HD is not well suited for 3d modeling to start with, and a 5 year old driver is a guaranteed problem.

Run windows update 1st and make sure you have everything windows related updated fully. You may have to run windows update several times (like 5-6 or more times)

Then update your driver. If it complains about not being a validated driver, see this article how to get around that and get the latest and greatest driver for your intel-

Thank you. I have updated the driver and everything seems to have settled down again. I really appreciate everyones assistance.