Rhino crashes when I try to render/use raytraced (mac)

I just switched from Rhino 6 to Rhino 7 and I am experiencing a lot of problems; Rhino crashes all the time and when I try to use raytraced or render I get the spinning ball and it says the application is not responding. I did not experience any of that with Rhino 6, does someone know what I should do? Using a 2017 Macbook Pro (MacOS Catalina, 3,1 GHz Dual-Core Intel Core i5, 8GB memory). Thank you very much.

Have you sent in crash reports to us when after a crash the crash reporting dialog pops up? Filled out your e-mail address so we can look it up?

I assume you have already updated to Rhino 7.1. If you haven’t yet, please do.

Thank you for the quick reply. My Rhino is up to date (7 7.1 is what it says). It doesn’t completely crash, I get the spinning ball and I always have to force quit it and at the force quit menu it says that the application is “not responding”. Even then, I get a pop-up thing from Rhino which says a crash report will be ready in a few minutes, but I never actually get it and I don’t know where to find it.

Does this spinning ball happen even if you do only the following:

  • Start Rhino
  • New empty document
  • Add a Box
  • Switch one viewport to Raytraced

No, all of these work fine. I think something is wrong with the file; I tried SelBadObjects but there none, so I am not sure where the issue is coming from. The file is too big to attach here, so I am sending a link https://drive.google.com/file/d/1msyPqMGvXX0mJv1lzIsxdHU_jQ92qDfE/view?usp=sharing

Thanks, I’ve just requested access from my mcneel address.

While I wait for access and FWIW, most of the desk scene in the PBR feature page I did on my Mac using Raytraced much of the time:

Can you try using this link instead? I can’t find where I can accept people and this one should work if you have the link: https://drive.google.com/file/d/1msyPqMGvXX0mJv1lzIsxdHU_jQ92qDfE/view?usp=sharing

Thanks, that link worked

On both my Catalina MBP and my Big Sur MBP the file opens and agrees to switch to Raytraced. The Big Sur machine is one similar to your MBP. I do see the beach ball for a short moment, but eventually the Raytraced viewport is running.

Hi again, I just upgraded my os to Big Sur and it worked; it’s rendering normally. Thank you very much for the support!