Rhino Crash whenever i open a rhino file

Good Day All.

I am hoping someone here could shed some light on the issue i am facing.
I have a large library of rhino files, all design work ive done over the years. I seem to be facing an issue that i cannot resolve. Whenever i open a rhino model, Rhino crashes. Its not model specific this happens to each and every model i open. The only way i have been able to open a model is by using the Rescue3dmFile command and by importing the file. I have tried opening through explorer, by using the open function in Rhino. The result is always the same. Crash report. I have also tried to open files using my notebook instead thinking it might be an issue with the desktop but the issue is the same on the notebook. If i do a design on the notebook i cannot open it on the desktop and visa versa. I am at a complete loss and would appreciate assistance

Thank You

Hi -

Do I understand this right - if you do a design on the notebook, you can open it on the notebook without problems?

Correct. However i cannot open any other rhino files.

What happens when you launch Rhino from the desktop icon?

Hi Wim

No issues with opening rhino at all. only issues with opening a rhino files.

Hi Justin -

Well… apparently only in specific cases. Launching Rhino from the desktop icon opens a factory-default template file, which is a file like any other.
So, it is starting to sound more and more like there is an issue with where the files are stored, perhaps? Is it only files that are stored on some network that are giving these problems?

Yes I am using a WD mycloud home to store the data.

That sounds like an NAS drive, which is not equivalent to a local drive.
You can not use a NAS drive as if it were a local disk.

As a test, move a few files to your local drive and see if you can edit them there without issues…
If you can then continue doing that and when you have exited Rhino make backup copies to this NAS drive.