Rhino crash during save

Hi all. I would like if you experienced this kind of problem.
Recently rhino6 crashes when autosaves the cad model in which i’m working.
This is an annoying thing because it does the same using various cad models and i can’t find the way to continue the work.
Apparently it seems that it tries to download some files .png from the serve . I don’t know why it looks for those images but expecially how to solve.


Could someone give me a suggestion?

I add some other informations.
I opened now another cad model with no material or textures,and shut down the internet connection.
Rhino gives some error , but still impossible to save.

These are the Rhino info
Rhino 6 SR18 2019-9-23 (Rhino 6, 6.18.19266.14201, Git hash:master @ 3d84f88dec99b2f4e8b7497e739ed2adc2ba8ef6)
License type: Commerciale, build 2019-09-23
License details: Cloud Zoo. In use by: Alessandro ()

Windows 7 SP1 (Physical RAM: 16Gb)
Machine name: AKESPORTABLE-PC

Hybrid graphics system.
Primary display: Intel® Iris™ Pro Graphics P580 (Intel) Memory: 1GB, Driver date: 10-2-2017 (M-D-Y).
Primary OpenGL: NVIDIA Quadro M2200 (NVidia) Memory: 4GB, Driver date: 9-19-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.94

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-19-2019
Driver Version: 26.21.14.3194
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.18.19266.14201
C:\Users\AkesPortable\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Thea For Rhino (0ab51401-0ca2-45e3-94e0-46d77b129353)\2018.3.18.0\Thea_V2\TheaForRhino.rhp “Thea For Rhino”
D:\Scan&Solve Pro for Rhino 6\SnSPro_Rhino6.rhp “Scan&Solve Pro for Rhino” 1.0.0.0
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.18.19266.14201
C:\Program Files\RhinoHyd\RhinoHyd_6_0_1.rhp “RhinoHyd”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.18.19266.14201
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files (x86)\Evolute\EvoluteTools D.LOFT for Rhino 6\EvoluteCoutHook.rhp “EvoluteCoutHook”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”
C:\Users\AkesPortable\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.8.24.259\SectionTools.rhp “SectionTools”

I see a couple of things.
Your Intel P580 driver needs to be updated because your system is a “hybrid” system that uses both display adapters.

My other guess is this may have something to do with plug-in data.
As a test, try this:

  1. In Rhino Options > Plug-ins, change the list filter to Plug-ins that do not ship with Rhino. Disable all of them including Thea, Scan and Solve, RhinoHyd, and Evolute.
  2. Close and restart Rhino without them
  3. See if you can repeat the crash.

My guess is Rhinbo will not crash.
Then systematically enable one of the plug-ins, restart, and repeat the test until you find the offending plug-in causing the problems.

Thanks John.
First of all, i checked that “intel driver and assistent software”, that runs everyday finding updated drivers, did not want to update IrisP580 because it says that my driver is custom-modified by Dell (bah).
So i am updating manually.
As for the “hybrid system”, i guess all the workstation notebooks have the intel garbage and the serious graphics as separated, isn’t it?

Thanks for your suggestion, i try now and let you know

Tried unsuccessfully.
First of all, intel can’t update since the "driver that you are installing is not valid for this computer, ask the computer manufacturer for the correct driver "
Obviously Dell has only the old (my current) version.

cg1

Second, i disabled all the plug ins, nothing changes.
Rhino can’t save the file. I opened the same file with Rhino 7 WIP, also it looks for that damned floorboards.png and gravel.png but at least it saves. Saving as Rh6 version from WIP, again Rh6 can’t save the file and crashes.

Driver now updated

Windows 7 SP1 (Physical RAM: 16Gb)
Machine name: AKESPORTABLE-PC

Hybrid graphics system.
Primary display: Intel® Iris™ Pro Graphics P580 (Intel) Memory: 1GB, Driver date: 5-29-2019 (M-D-Y).
Primary OpenGL: NVIDIA Quadro M2200 (NVidia) Memory: 4GB, Driver date: 9-19-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.94

but nothing changed

You could click the hamburger menu in the materials panel and select to download all textures. It’ll take a while, but after that you should no longer see attempts to download textures.

tried… but it doesnt run!

probably the core of the problem is here?

ok… i tried the command for the italian version: “scaricatexure” (yes, the “t” is missing)
and downloaded all the textures.

image

Yes, the problem seems to be solved!

Thanks a lot Nathan

None. Unfortunately, it doesnt run. After a make2d , Rhino is crashing again with the same message

But it seems that problem occurs when importing a Rhino5 file

after many attempts i found the solution. Problems occurs if I import a model saved previously in Rhino5 using the option “save plug-in data”. It needs to open this file in Rh5 or 6, save again without plugin data, and then it can be imported in Rh6 without errors. Hope it is helpful if someone has the same trouble.

1 Like

thanks for all your tests, it will help a lot to other users ( if they search in the forum before asking… but that’s another issue haha)

2 Likes