Rhino corrupts my files


I’m facing the following problem: when working on a previously created file and saving it (overwriting existing file) a message occurs reading that the file is opened in read-only mode, so I can only save it as a copy. It also happens so, when I create a new file, save it as a fresh file and then save it again (overwrite). Moreover, once a message occurs after failed save attempt, the original file breaks up - it can’t be opened anymore by Rhino. Firstly, a message occurs that the file is in read-only mode and I can chose between not opening it or opening it in read-only mode. Secondly, when I select read-only mode, another message apears saying “Unalbe to open file: File access denined”.

I already tried to disable *.rhl files, but it didn’t helped.

Aditionally I’m unable to update Rhino. The installer displays a message, saying that downloading was unsuccessfull. Maybe the instalation log would be helpful to find the source of the problems.
Rhino_7_20230315223922.rar (3.5 KB)

Finally, several weeks ago I had the same problems with file saving and installations (whether uptates or clean installations of Rhino). The problems were gone (for a while) after updating Windows - automatic update from 10 to 11. Today my Windows prepeared a new update, but problems with Rhino occured hours before I had confirmed that update.

Please help.

Hi Michal,

Lets start by getting your .Net repaired and then do a Repair install of your Rhino.

Hi Japhy,

Ok, I got my .Net repaired both through the Net repair tool and Rhino repair (just to be sure). I also ran VC reinstaller (the fourth step in the link). For that I had to relog to my admin account, becouse at my daily one the VC reinstaller responded with errors. The problems with Rhino however, still occur - strangely only at my daily accont. Under my admin account saving and updating works well. Could anything else be the solution?

One more thing. I tried Rhino on another, standard account on my computer (without administrative premissions) and everything works fine there. I think my daily accont may somehow cause the problems. Anyway, if you can think of a solution it’d be great.

When you say login to Admin is this your windows admin/user or various Rhino Accounts? If that’s so this is pointing towards User Account Control permissions or anti-virus software.

I mean my windows accounts. I’m going to check these settings and let you know.

I checked the UAC setting for both standard accounts and they’re at the same, default (top) level. So I changed that setting one level down on the account where Rhino is’t working well and disabled antivirus. Rhino is still having troubles with files despite that.

Was Rhino installed as Admin? Having Rhino work as expected on admin is pointing to something along these lines (or anti-virus).

After the .Net repair & Rhino repair were you able to update Rhino?

I ran your log…

Possible Solutions:

  1. Cause: Failed while caching. The installer is trying to save important information on your computer to allow future upgrades and uninstalls, but may be being blocked by antivirus or malware protection software.

2.Solution:* Temporarily disable your virus scanner, then run installer again.

Actually I did the last upgrade of Rhino on the admin account, right after VC reinstaller done there. Now I can’t tell whether disabling antivirus would let the update installer to go through. Should I uninstall Rhino, disable antivirus and install it again?

Disable anti-virus and then do a repair, the repair will ensure everything is fresh and where it should be. The uninstall - re-install not so much.

Email tech@mcneel.com if you’re still having issues, the European (Spain) tech support will be available in the morning. Be sure to include this thread.

1 Like

Ok, I did so. I disabled antivirus and run a repair. Saving files is still not working properly afterwards.

I will contact with European tech support then. Thank you Japhy for your aid!