Rhino opening every file as read only?

running v6 SR27, i think i just updated within the hour, all my files are opening as read only now.

Hello - if you open a file from the desktop - does that open read only?

-Pascal

yeah, it does

Hm - what message do you see, if any, as you open? Can you make a screen shot of that?

-Pascal

ERROR

EDIT: oh sorry, that’s the error for the attempted save. i get no warnings when opening the file

Hello - if you find that file in Windows Explorer, and look at its properties, is it marked as read only by Windows?

-Pascal

it’s unchecked

A couple of things before I call on the bigger brains - are you logged into Windows as Administrator? Does anything change if you right click on the Rhino icon and choose ‘Run as Administrator’? And, I assume but just making sure, Rhino is the only affected program? You can save from say Notepad or something?

-Pascal

logged in as admin, same behavior with running rhino as admin, and it’s the only program that is having the issue. i’ve even rebooted twice.

@kleerkoat - if you do save via SaveAs, can you then Save or must you SaveAs again?

-Pascal

have to use SaveAs

OK- thanks - even the smarter people than me are mystified by this behavior, so we’ll probably ask more useless questions until we get to the right one… so other saves from Rhino work as expected, Export, ViewCaptureToFile , even a Grasshopper document would be worth a try ?

Also, please run SystemInfo and post the results… you never know what plug-in might be getting involved somehow.

Does anything work differently if you run Rhino in Safe Mode, btw?

To start Rhino in Safe Mode: Windows start menu, type in ‘Rhinoceros’ and look for the ‘Rhinoceros in Safe Mode’ entry.

-Pascal

other saves work as intended, safe mode still read only, thanks

Rhino 6 SR27 2020-6-11 (Rhino 6, 6.27.20163.15081, Git hash:master @ 8c9f18774d0fe24946068d123d78712d7a17f847)
License type: Commercial, build 2020-06-11
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: RGILMORE

Hybrid graphics system.
Primary display: Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y).
Primary OpenGL: NVIDIA Quadro P1000 (NVidia) Memory: 4GB, Driver date: 4-7-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.92

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  
  Anti-alias mode: 8x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: Height
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 4-7-2020
  Driver Version: 26.21.14.4292
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 4 GB

Rhino plugins
  C:\Program Files\Rhino 6\Plug-ins\Commands.rhp	"Commands"	6.27.20163.15081
  C:\Program Files\Rhino 6\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp	"RhinoScript"	
  C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp	"Rhino Render"	
  C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	6.27.20163.15081
  C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Users\monke\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp	"PanelingTools"	
  C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp	"IronPython"	6.27.20163.15081
  C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	6.27.20163.15081
  C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp	"Grasshopper"	6.27.20163.15081
  C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	6.27.20163.15081
  C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Users\monke\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\ColorPicker\6.0.0\ColorPicker.rhp	"ColorPicker"	
  C:\Users\monke\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\raytraced-materials\0.1.3+v6.15\RaytracedMaterials.rhp	"Raytraced Materials"	0.1.3.0
  C:\Users\monke\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\SectionTools\2019.7.29+584\SectionTools.rhp	"SectionTools"

Could you try going to the “Options/Files” page and un check the “Enable file locking” option. When this is done try opening and saving a file and let me know if it makes a difference. I would not recommend leaving this option off as a long term to your problem but am interested to know if it affects the save behavior.

Thanks for the report and details - we can repeat this here now.

RH-59194 Files read-only if file locking is off

-Pascal

1 Like

RH-59194 is fixed in the latest Service Release

1 Like

I am having the same issue. I have the latest version of Rhino 7. I am not able to save my file.

error

Hi -
Do you have this issue with any file?
Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

Rhino 7 SR7 2021-6-9 (Rhino 7, 7.7.21160.05001, Git hash:master @ d2161989109d5dacba531310b5d345ce6f4da9f6)
License type: Educational Lab License, build 2021-06-09
License details: LAN Zoo Network Node

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro K2200 (NVidia) Memory: 4GB, Driver date: 5-6-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 462.59
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
Citrix Indirect Display Adapter (Citrix Systems Inc.) Memory: 0MB, Driver date: 1-23-2019 (M-D-Y).
> External USB display device with 8 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-6-2021
Driver Version: 27.21.14.6259
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino7.rhp “Karamba3DLicense”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.7.21160.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”