Trying to save but "Read Only Mode" error comes up

Hello,

I am a student running Rhino 7. I have been working on a file for a few weeks now and when I attempt to Save a error occurs saying “File opened in read-only mode. You must use SaveAs to save changes”. Is there a way to prevent that from happening? I have no intentionally turned on Read-Only mode, and I do not want multiple copies of the same file. Any advice would be appreciated

It may be that Rhino has crashed at some point. You’ll probably find a file ending with the extension .rhl. If that is the case remove that .rhl file. You should be able to open the file again in read-write mode.

Hey @nathanletwory, I am getting this bug all the time since ~2 weeks, which is super annoying. The files are definitely not read only and there is no .rhl present.

I would be very happy if McNeel could tackle this, before it never occured to me in this way.

1 Like

Hi Max,
Please run SystemInfo and paste the results here. I would like to figure out what is causing this issue on your computer.

Hey Steve, here is the SystemInfo.
Any help appreciated, thanks!

Rhino 7 SR5 2021-3-23 (Rhino 7, 7.5.21082.11001, Git hash:master @ 944c103dcfd368bc1974c8866461f0c7bf5ae9d3)
License type: Studentenlizenz, build 2021-03-23
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [79% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-18-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce GTX 1650 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 3-10-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.92
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-10-2021
Driver Version: 27.21.14.6192
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 7 WIP\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino7.rhp “Karamba3DLicense”
C:\Users\EFESTWIN\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\TeDAsharp (ce983e9d-72de-4a79-8832-7c374e6e26de)\1.0.7325.19068\TeDaSharp_040.rhp “TeDAsharp” 1.0.7325.19068
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020” 1.0.6.0
C:\Users\EFESTWIN\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.0\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.0.0
C:\Users\EFESTWIN\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SubstanceImporter\1.0.0\Substance.Win.rhp “SubstanceImporter” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.5.21082.11001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.5.21082.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.5.21082.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.5.21082.11001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.5.21082.11001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.5.21082.11001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Did you install Hops? If you did, please run PackageManager and make sure you have the most recent version.

1 Like

Oh yeah this might be the culprit. Indeed the version was a little outdated. After the update I had no such issues yesterday. Fingers crossed that this was it :wink:

Thank you for your immediate help Steve! Greatly appreciated :slight_smile: