Rhino causing internet issue (connected, no internet)

So I just wanted to put this issue out there for people interested - it’s a bit of a puzzle game at this point, no real harm but just makes me really, really curious. The issue in short is that rhino kills internet connection, similar to what’s reported here: Rhino kills my internet connection.

But here’s the full story.

About six month ago, I was suddenly starting to have internet issue - my wifi would be in a “connected. no interenet” state. I should mention that I made no changes to drivers or anything in the operating environment.

Interestingly the issue developed gradually - at first spotty, connection would be down only once in a while, then it disconnected for prolonged periods, but a reset of internet adapter would solve it. It took several weeks if not longer to get to the point where it just wouldn’t give me internet. I then looked up the issue, tried all sorts of remedy, to no avail.

Finally I randomly decided to pull out my backup router and plugged it into my main router, and it worked. The internet was back, no issue since.

At the time I did not associate this issue with rhino, but just I thought something was wrong with my router. Brought a new one (different brand), but didn’t have time to install it until last week.

Then, as soon as I started rhino, the “no internet” issue happened. I know clearly this time that it’s rhino, because as soon as I shut down rhino, internet comes back. Works like that every single time. Open rhino - no internet; close rhino - internet. As you’d guess, I pulled out my backup router again, and it worked, again.

I am not really bothered by it right now, since it is working. I wanted to post this for two main reasons, a) to give someone having the same issue a possible remedy; and b) I am really curiuos what’s happening. I tried all remedies suggested under the post linked above now I know it’s a rhino issue, including safe mode, editing the registry to stop rhino’s internet access, among other things. Nothing would work but adding another router? Doesn’t make a whole lot of sense to me (yet)