Rhino kills my internet connection

I am using the 3 month trial version of RHINO 7 for school. Sadly when I open the program my internet connection dies. I know the issue is limited to my laptop (pc) because I still have a connection on my phone.

I have tried allowing RHINO through my firewall, even turning the firewall off to see if that helped, but still, when I open RHINO 7 -or- 6 my connection stops. Is there some setting in the program that might effect my wireless connection?

I don’t think if Rhino uses the internet connection too much.

Any ideas on this one @brian?

1 Like

Hi Mark,

That’s a strange one that I’ve never heard of before. There’s an advanced setting to tell Rhino to not touch the internet. Here’s how to see if it helps:

  1. Close Rhino
  2. From the Start menu in Windows, type regedit then press Enter
  3. Browse to HKEY_LOCAL_MACHINE\Software\McNeel
  4. Set the DisableInternetAccess value to 1
  5. Start Rhino

If DisableInternetAccess isn’t in your registry:

  1. Right-click the McNeel folder, then click New > String Value
  2. Name it DisableInternetAccess and set the data to 1

Does this change what happens when you start Rhino?

I changed the value to 1 in the registry, sadly that did not fix the issue. I still lose my connection. Might changing my license to a cloud type instead of a single computer license work? Not sure how to do that.

This is pretty weird.

First thing I’d do is set DisableInternetAccess back to 0 - it’ll cause you other problems if you don’t.

Second, can you make sure you have all the latest Windows Updates installed?

Third, can you send me a screenshot of whatever you’re using to determine that your internet connection dies?

Windows is all up to date. I know my connection is lost because none of my programs that require a connection work like MS teams, also I cannot load any web pages in my browser. Eventually my computer will tell me the wifi I am connected to has no web connection, which is not true because my phone is connected. Then after a bit, I disconnect from the wifi all together. Again, connection issues are remedied by simply closing RHINO.

That’s pretty odd. I’ve never heard of this before (or at best only once).

How about this:

  1. From the start menu, type services then press Enter
  2. In the services list, find McNeel Update Service
  3. Right-click McNeel Update Service and click Stop

Does starting Rhino still disable your internet?

I assume that when you say your phone still works you mean over the wifi using the same router as your computer, not the cellular connection? I would hazard a guess that you are losing the connection between the computer and the router. Check the network connection status at your computer.

Since the Rhino update service runs all the time and you only lose the network when Rhino is run, I doubt the update service is the problem. It must be something associated with Rhino’s attempting to use the net while running. Or even just something else in Rhino that interferes with your wifi connection.

Another thought: is the subject wifi connection your own, or is it your school’s?

Turning the update service off did not work. And the wifi is at my home. I do not have data on my phone so if something was strange with the wifi router it would have no connection. I have never encountered these issues before with this computer. It’s only a few months old. When I run the network troublshooter it tells me the wifi I am connected to has no internet connection, which is not true. As usual, when I close RHINO everything pops back online.

I take this to mean that you have “cellular data” turned off on your phone so any data-driven phone activity (email, text, browsing, etc.) MUST be coming via the wifi connection, and that this phone activity continues normally while your computer’s network-based activity doesn’t.

As you are probably aware, the router connects to the Internet Service Provider’s (ISP) user side connector with a single wired ethernet connection. All the data for all the devices using the wifi goes back and forth over this connection. So if the ISP or the router hardware fails for some reason, every device trying to use the wifi connection will fail. On the other “side” of the router there are multiple wireless “connections”, one for each device using the wifi. It’s entirely possible for one of these connections to fail for certain reasons (rendering the associated device’s internet connection inoperative), while the other devices using the wifi are unaffected. This appears to be what’s happening to you.

Two possibilities come to mind; there are probably others.

  1. Some kind of IP address conflict between your computer and the router; ie your computer is trying to use an IP address that the router has assigned to some other device or is outside the address range the router is configured to use. This would make it impossible for your computer to do anything on either the Wide Area Network (WAN) ie. internet or your Local Area Network (LAN) ie. file or printer/scanner sharing.
  2. Your router has been configured to prevent internet access for the IP address your computer is using. This is called “parental control” on many routers. This would result in no WAN access for your computer but would not affect its LAN access, so you could continue file sharing and printing.

Why either of these conditions would be initiated by Rhino is a complete mystery to me, which is why I said “there are probably others”.

I certainly hope you get it resolved and wish you good luck.

Hi @drennon.mark,

a) Try running the Safe Mode version of Rhino and let us know if you still lose your connection. Safe Mode limits functionality (for instance not loading plugins) so is a good way to help McNeel identify where the cause might lie.

b) Try running the Internet Connections Troubleshooter from Windows Settings while you have lost your connection. Let us know if that fixes it and, if so, whether the fix lasts.

c) If you have antivirus software or VPN software installed, check their logs for relevant messages from the time when Rhino is running.

d) Is there someone from school who has Rhino on a fully working laptop who could come round and connect to your Wi-Fi whilst you are disconnected and see if running their Rhino encounters the same problem?

Hi Jeremy, since this thread has fallen silent I thought I’d add my own input.
I’ve been having exactly the same problem as Drennon since updating to Rhino 7 just over a week ago. I’ve tried everything else on this thread and nothing has worked, however running the Safe Mode version does not kill my internet connection. I also tried running the troubleshooter as you suggested and got this result:

I’m not really sure what the cause of either of these problems is or how it could be linked to Rhino, but I’ve yet to have this problem with any other software.

Have you guys tried to block rhino.exe with a firewall rule?
Since the license is read through "localhost: … ", after you registered your license once, you should be able to have stay offline for a while.

Hi @mcferne,

Could you run the SystemInfo command in the full-fat Rhino and and post the output here so the McNeel guys can see what plugins you have loaded?


Here’s all the plugins listed, could it be related to the Twinmotion plugin?

One more thing, I discovered just now that plugging the charger into my laptop instantly fixes the problem, so it’s only occurring when my laptop is running only on the battery. Of course, I’d prefer for it to work either way but it’s an okay solution for now.

OK, so I’d take a look at the power management settings - sounds like your laptop is turning off the wi-fi to save juice when running a heavy load under battery.

Hi @mcferne,

Has this helped you fix the problem?

Hi all, I am having the same issue. Installed rhino 7 evaluation and internet went down. Whilst installed i tried hotspot via phone and router wifi connection, all displayed a strong connection, just wouldn’t receive anything on chrome or apps. As soon as I uninstalled Rhino 7 and restarted my computer the internet was working fine again.

I am having the same issue!
When I run the program, the WiFi connection is disconnected and no matter how much I click on the connect again (WiFi connect automatically is enabled as well) it will not connect.
As soon as I exit the program, the Internet will be connected!