Rhino can not start because your license is already in use


I opened a DWG file (which was created by exporting from Revit).
This DWG file loaded, but for some reason it froze Rhino - I can’t type a command, can’t access any toolbar, nothing. It just shows the DWG file’s geometry in Rhino’s standard 4 Viewports. I thought DWG was buggy, and tried to open in Autocad. It opened without issues.

I waited few hours to see if Rhino will get unfrozen, but nothing changed.
I couldn’t close that Rhino from Windows task bar, nor from upper right “X” button. So I closed it with Task Manager.

And this is where the problem starts: After shutting down that Rhino instance with Task Manager, I can not run Rhino again. Whenever I try to run a new Rhino instance, it starts loading, and stops at the step: “Retreiving licence from License Manager”. Then it shows the following error message:

Rhinoceros Rhino Already Running

Rhino can not start because your license is already in use by another user on this computer

I am the only person who uses this computer. Rhino is installed as version 6.35, offline license. We don’t have Zoo. On Windows 10.

I tried restarting; shutting down PC. Disconnecting the internet; running Rhino as administrator (right click on Rhino shortcut-> Run as administrator) and none helped.

Is reinstall of Rhino, the only solution?

Thank you very for any kind of suggestion.

Best regards,

Hi @djordje,

Are you logged into this computer with more than one account?

— Dale

1 Like

Hi Dale,
Thank you for the prompt reply.
This is company’s PC, used only by me (nobody else logs to it, but me).

Have you logged out and back in, or rebooted?

— Dale

1 Like

Hi @dale,

I tried both restart and shut down of the PC. No effect.
But I never tried to “Sign out” from Windows account. Good advice, I didn’t think of that.
I will test it on Monday. Thank you for the suggestion.

Restart is almost the same as shutting down, both of which could be called “rebooting”. Either way, all users are automatically logged out. Even if you forcefully shut off the power without logging out Windows will require you to signin again when you power up the next time.

So in my opinion your answer to Dale is “Yes” and I wouldn’t expect success on Monday and something else must be wrong such as a corrupted or missing license file. I hope I’m wrong.

1 Like

Hi @dale . It worked!
I “Sign out” from Windows account (CTRL+ALT+DEL → Sign out) and now License Manager is again able to find the license!
Thank you very much for the help Dale!

Hi @AlW ,
It’s been more than a decade, since this is not true anymore for Windows operating systems. Since release of Windows 8, and Fast Startup feature, shutdown no longer “clears out” RAM, and processor cach.
Even if you unplug the power cable from the computer, which has just been shut down, it is not a guarantee that upper mentioned computer components will be “cleared out”. It may be that you have to wait for a certain time until different computer components are physically refreshed.

That’s why for any kind of software/hardware issues on Windows, the first advice is to restart, not shutdown.

I appreciate your willingness to help though.

1 Like