Rhino can not quit. (only forced exit)

OS X 10.9.5 Rhino 5.0.1.
2 days I have a serious problem here. Rhino after saving a file is not closed, and does not respond. It is necessary to use force quit. I enclose a video.

Rhino problem exit .mp4 (11.5 MB)

This sounds like a localized problem (specific to your machine)

Try restarting then reinstall Rhino, remove and archive the McNeel plist file that contains your setting too. Rhino will create a new plist, and you can restore the old plist later if that is not the problem.

After doing the above, does the problem still happen…wilth all Rhino files or just a single file? Single points to the specific file.

In the past, restore the file plist did not work for me (did not have any effect on the settings). Too much risk of losing custom commands. If I have to do this procedure I want to be 100% sure that will have no effect on my work.

You will not loose your settings if you do this right, unless, of course, the problem is in fact a corrupt plist, which it may not be, but you are seeking to rule that out.

  1. Exit Rhino

  2. Copy the plist to the desktop from /Users/*YourUserName/*Library/Preferences.

  3. Delete the Mcneel plist from /Users/*YourUserName/*Library/Preferences

  4. Start Rhino to have a fresh plist created.

If this does not solve the problem, exit Rhino, delete the newly created plist in Preferences and put the original plist containing all your settings back into Preferences. This will restore your settings.

You should be archiving your important com.mcneel.rhinoceros.plist file anyway for system restore, etc. Incremental backups of com.mcneel.rhinoceros.plist will help restoration too in the event of plist corruption.

Good luck!

PS…if you use TimeMachine you have incremental backups of com.mcneel.rhinoceros.plist already

Proven steps, no positive result. Even opening a new file and trying to close Rhino, appears colored ball and I can only go out with forced exit.

Good…sort of. Lets rule out plist for now and individual .3dm file corruption.

You reinstalled Rhino prior to the plist test correct? That was an important step.

Please forgive this question if it does not apply to you…but I have seen the following on others computers and it creates all sorts of issues (obviously)…is your boot hard drive full?

I reinstalled AFTER proof of .plist. The HD (fusion drive 1 TB) has about 400 GB available.

start up in safe mode. issue gone or still exist in safe mode?

Also proven safe mode. The problem also in that case.

Huh…tough case then if still bad in safe mode.

Though I’ve enjoyed trying to help, I’m going to need to focus on my work so can’t help you much more today. Perhaps others here have some more ideas…

I’m leaning towards a Draconian solution for you, but you may not like it - clean OS install (not an update), reinstall your apps, restore your data, assuming you have the time and skills to do so. If you go clean, suggest 10.10.4. Clean installs can be very beneficial.

Good luck!!!

Thank you for your time.

mcneel is working on it from their end. I’d monitor this posting to see if they are able to help you

Update: After some tests I have identified and “solved” problem. I uninstalled the software 3D Connexion 10.2.2 (the latest available), and the problem has disappeared. I installed the old driver and Rhino 10.1.2 operating normally and closes immediately, I reserve a few hours to see if there are improvements on the annoying freezing during pan and zoom.
I had a similar problem in the past with my Wacom tablet (I use with Rhino). Even in that case, the removal of the driver (the latest available) and the installation of the previous one has solved the problem.


See this thread.

This ought to be fixed the most recent 5.0.2 release.