Viewports freezing after canceling 'close file'

After choosing cancel in the close file dialog all my viewports freeze. Menus are still working.
I have to save and reopen the file to be able to continue working on it.
Restarting Rhino ain’t necessary.
Happens with every file.

Rhino version: 5.0.1
OS X 10.10.4
MacBook Pro (17-inch, Early 2009) / 2,66 GHz Intel Core 2 Duo / 8 GB 1067 MHz DDR3 / NVIDIA GeForce 9400M 256 MB

Same problem here. I have to use force quit every time. OS X 10.9.5 Rhino 5.0.1

This sounds frustrating. I’m hearing more reports of this lately. I could use your help testing a theory…

I suspect Rhino for Mac’s preferences might be the culprit here. What happens when you reset the preferences? Please follow these steps. The only minor amendment that I would make to these directions would be to ignore step 4 in the final Restore saved Rhino Preferences section. Instead, move the com.mcneel.rhinoceros.plist on your desktop (in case this is not the problem)…so we can copy it back if the experiment does not work.

One other question: Are either of you using Time Machine?

Hi Dan,

Tried what you suggested, no use unfortunately.
I don’t use Time Machine for wireless backing up. Only through usb now and
then.

Dan, I did a fresh install of 10.10.4 and it cured this fault when I just installed Rhino beta, unfortunately I required all my email and other files so did a time machine restore and got the fault back.

I have just picked up a secondhand Mac I am setting up as a dedicated Rhino machine. Will see if this fault occurs when I finish all my install.

Having completed install and tests. Rhino now behaves normally with fresh install, no failed exits from application.

That is great to hear. It’s still concerning. This sounds suspiciously similar to this thread.

I have a sneaky suspicion it maybe due to legacy files from updates as I can’t find any app that seems to cause the issue and the fact all the drivers are fresh on a new install… Life too short I’m afraid to wade through it and find the fault. My sys admin days are over. LOL

Hmmm, just installed Cura 15.04 and the fail to exit has returned.

I have uninstalled Cura, and as luck would have it… The fault has not gone :angry:

I still doubt it’s as simple as just Cura. Pretty sure something else is getting turned on/off so it may not be just Cura that trips it.

:smile: given…

Hmmm, just installed Cura 15.04 and the fail to exit has returned.

Interesting. @JosB, @Zsimon, do you have Cura installed by any chance?

Yep…and a preference refresh, reinstall, and safe boot did not help @Zsimon

I’m running the WIP, not 5.01. I wonder if these guys should try the WIP, if there is any chance at all some difference is related? I would not know. Can’t hurt…

Those affected could also try repairing permissions just in case Rhino is being block writing something on exit?


Yes, I “Cura” installed

Hmmm, confirmation of smoke…

Can/did you uninstall Cura? Problem go away after uninstall?

I uninstalled Cura following the procedure of removal of preferences but the problem remains. A doubt, I have to get into Rhino and restore the preferences to the default?

there might be a hidden folder…try these instructions if you have not. i only glanced at them

I can not access the link. Can you kindly do a copy paste of the procedure?

Never mind. I was able to access the link now.

Another interesting little snippet. I started having trouble with my SpacePilot Pro in Rhino not recognising the FIT button macro. I tried different things and confirmed the button was working in the 3D Connexions test. Finally I uninstalled it thinking I would start again. My Rhino shutdown fault has cleared… YES Cura is still on the system. As I fear, this fault isn’t really tied to an app but maybe some sort of system setting that gets toggled by God knows what…