Rhino blocks it just me? Help me understand

I did as you wrote. The complete model, using the command “TestListTables” were 42 bitman (all high resolution …) After copying and pasting into a new file, no longer bitman.
The file size dropped from 284 to 182 mb.

testPurgeBitmapTable may help - but it gets ALL bitmaps in the table - it does not ask any questions, so beware…

( This is a test command and will not autocomplete, “use at your own risk”)

-Pascal

WIP 5C249w
I continue to have big problems of slowing down. Each time it is performed automatically save, Rhino crashes for about 7-10 seconds. If the save is done while I’m doing the orbit with 3D mouse connection, after saving the object moves with the speed in the direction that I was following orbit.
Note that when you save, I can still move the cursor using the mouse (wacom in my case). Right now I’m working with a file that contains the following parts.

Summary of the audit:
Schedule tables:
43 levels
2 dimension styles
3 fonts
5 types of line
118 render materials
Calculation objects:
231 normal objects
3 locked objects
1445 hidden objects
583 deleted objects (in the undo buffer)
0 objects definition block
0 normal reference objects
0 reference objects blocked
0 reference objects hidden
0 items framing reference block
No error.

Please upload your model using this link http://www.rhino3d.com/upload so we can see what is in your model that is causing the delay. Thank you.

We received the model you sent to us. Please copy your Rhino information from Rhinoceros > About Rhinoceros > More Info > Copy to clipboard and post that information here.

Software information

Software versions
Rhinoceros version: 5.2 WIP (5C249w)
IronPython version: 5.1.2015.131
Language: it (MacOS default)
OS X version: Versione 10.11.5 (Build 15F34)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Third party kernel extensions
com.3dconnexion.driver (10.3.1) 351F5729-EB92-3F08-B022-6206FCA697E9

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470 CPU @ 3.20GHz
Memory: 32 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 680MX 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Inateck USB to SATA3 Bridge: Inateck Generic USB Device
GenesysLogic: USB3.0 Hub
Lexar: WorkflowD512
3Dconnexion: SpaceMouse Pro
Wacom Co.,Ltd.: CTH-460

Bluetooth devices
Apple: Apple Wireless Keyboard
Apple: Apple Wireless Trackpad

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.10.10 310.42.25f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bit
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: Yes

Appearance settings
Antialiasing: 4x
Mip map filtering: Nessuno
Anisotropic filtering: Nessuno

I have the model you just sent us and again I cannot duplicate the behavior you describe. Your model takes less than two seconds to Auto Save. The user interface is locked for less than two seconds. I am running on 10.11.5 with the 3DConnection 10.3.1 driver. I have tried both the SpaceNavigator and the SpaceMouse Wireless. These are the only two 3DConnexion devices we support. I see you have switched to a SpaceMouse Pro, which we do not support. That may be your problem.

When I measure the Auto Save time, I am using a special build of Rhino that displays to me when an Auto Save starts and when it ends. I would not be able to measure this time otherwise. An Auto Save will never start while you are using the mouse, keyboard, or 3DConnexion SpaceNavigator or SpaceMouse Wireless. An Auto Save might start if all of these devices are idle for at least 15 seconds, but there is no way to know when an Auto Save starts (and ends) unless you have a special build of Rhino.

You say that Rhino stalls for 7-10 seconds. How do you determine this?

This happens approximately every 5 minutes: I’m doing the orbit with the SpaceMouse Pro, suddenly appears the colored ball for about 7-10 seconds (calculated by looking at the time at the top right) after Rhino starts to work and the image of 'preview of the file finder is updated. It’s really frustrating. I could make a video, even if you would not see the colored ball.

I made a video where the block was 30 seconds !. I will post the link to the same address.

Does the same thing happen if the unsupported Spacemouse Pro is disconnected?

Mac Rhino will not perform an Auto Save when a 3DConnexion SpaceNavigator or SpaceMouse Wireless is active. Mac Rhino will not interrupt rotating or panning when using these 3DConnexion devices. I cannot make that guarantee with a SpaceMouse Pro because we do not support that device.

I suggested earlier in this thread that you perform an overnight experiment. I’ll repeat that suggestion here. I’ll also quote again the last paragraph of that post:

I think at this point you need to experiment with either another Macintosh, or create another OS X partition and install a fresh copy of OS X on the new partition. It seems at this point there is something with your particular computer environment that is part of the problem, because no one else can duplicate the behavior you are describing.

Hi John.
I performed two tests, the first using the Space Mouse Pro (34-second block with auto-save and update its image preview of the file on the finder, activity monitoring showing the Rhino block).
In the second test, unplugging the Space Mouse Pro blockage due to automatic saving was 2 seconds, exactly as said Marlin.
The first test, with 34 seconds of block was Recorder in a private video and sent to the support link

I remind you that earlier, on your display to install OS X on a new partition, I have done so by installing OS X on an external ssd and installing Rhino and moving the license.
The problems have remained and even worsened.
The problem is definitely something connected to the Space Mouse Pro and Rhino.
With other programs the Space Mouse Pro works perfectly.
In the private video I posted the problem can be clearly seen.
Add some items to try together to solve the problem.

  1. you are working on a file to about 1 year and a half
  2. have been created about 30 copies of files, export selected, copy paste to the new document. Some are located on external HD as backups.
  3. some files using the command _TestListTables include up to 40 bitman (background images are located in separate folders)
  4. Time Machine is activated about 1 time per week
  5. These are ALWAYS active 3 Pointing systems, Magic Trackpad, SpaceMouse Pro, Wacom Bamboo Pen & Touch.
  6. they are used in Rhino personalized menus
  7. The results of the Pro SpaceMouse keys have been configured as follows:

  1. El Capitan OS X is installed on the external Samsung SSD 850 EVO 500GB SATA 3.
    It uses an external housing for hard disk drives Inateck 2.5-inch USB3.0 cable for HDD and SSD SATA 2.5 "supports UAS. Currently 216 GB are free.

Mac Rhino does not support the 3DConnexion SpaceMouse Pro. We have stated that and explained why many times on this forum.

We are sorry you are having problems with the 3DConnexion SpaceMouse Pro, but we cannot fix this.

I sang victory too soon …
I thought I had found the cause of the problem but I was wrong.
Having tried again, even with the SpaceNavigator I get a block of about 30 seconds, Rhino does not respond (activity monitoring) and then preview the file on Finder is updated.
This after 5 minutes of use WHILE I’m using the SpaceNavigator to make orbit.
Note that the problem occurs in the same way by saving the file with cmd + S

The problem is thus presented both with the SpaceMouse Pro (not supported)
that with the SpaceNavigator (supported).

So far we have been performing different tests and getting different results. This does not prove anything. We both need to perform the same test to have a valid test.

I described an overnight test above. Would you please perform that test exactly as described and post your result.

@marlin tried to, and run the tests that you have offered me.
I have not run all night for this reason: carrying out the orbit of the spheres after 5 minutes nothing happens, just interrupt you spend about 30 seconds and the autosave updates the preview image (two seconds)
I repeated the same test, but totally abandons over time to make the orbit, I continually moved some balls, I copied deleted etc. After exactly 5 minutes Rhino crashed for about 30 seconds. The problem occurs then simultaneously using 2 pointing systems (3d mouse to the orbit and the Wacom or mouse or trackpad to edit objects.)
I also started the Mac in safe mode. Rhino does not respond you commands.

I am a hobby user of Rhino for Mac on a Macbook Air, and I would just offer this. Safari and the standard Mail program included with OS X seem to just grab all the memory they can and are just not good at giving it up. I always keep Safari closed when working in Rhino, and I refuse to use the standard Mail program period. I don’t think the problem described here is a Rhino AutoSave problem, its a Mac memory problem created by Safari/Mail - thus the color wheel of death. Close them and other unrelated programs; you will see better results. FWIW

I am still convinced that this is an issue with your computer configuration. No one else can duplicate this.

I have prepared a USB thumb drive for you. I have installed a fresh copy of OS X 10.11.6 on it, along with the 3DConnexion driver, Rhinoceros 5.2.1 and a few models. Nothing else is installed on this thumb drive. I boot from this thumb drive and cannot duplicate what you describe.

Please email your postal address to marlin@mcneel.com and I will send this thumb drive to you for testing.

thanks for that Marlin. Really. As I imagine you remember reading the old posts, this problem I carry around a long time. I will provide my address as required. If the problem is on my Mac, having installed El Capitan clean, the only program that I installed King was Rhino. Thank you again.