Rhino Beta - Check for updates error

Hi @brian,

if i click on the “Check Now” link in Options / Update and Statistics i get an “Application not found” error:

using version (6.1.17312.221, 08.11.2017)


You apparently are one of the victims that got an accidental 6.1 build. You should uninstall this one and reinstall an (older) 6.0 BETA and then check again.

Anwendung nicht gefunden - either you don’t have a default browser set, or some other interesting setting made for that?

Thanks @nathanletwory, i’ve now lowered the security setting to allow a browser doing something and get “Your installation is the newest available”. Will the Beta automatically update ?


I noticed an issue when I go to menu Help, then click Check For Updates… The Rhino Options menu pops up and fails to paint.

As I wrote you are one of the victims of a build error where 6.1 builds accidently went into the 6.0 stream. Since 6.1 is and will be much newer then the BETA builds published since it was released on the 8th you will get this message until the first actual 6.1 SR gets released. That is why I told you to uninstall this 6.1 build and find the installer for the previous build you had installed. Install from that, and then check again for latest BETA release.

What version are you using? (Help > System Information…)

if I click any of the menu options on the left it fixes itself

This is already fixed in a newer build, AFAIK.


p.s. Nice to see one of the last classic windows theme users (:

it seems to be grabbing firefox screen memory or something in the backgrouond, as I left it open as I was browsing and looked back to see the attachment.

(6.0.17318.8561, 11/14/2017)

ok, just loaded.

That is indeed already ‘old’. The BETA from last week should have that bug fixed already. You will want to update to that, even though the next BETA is probably just around the corner (best to update to that later in the week…)

thats a good thing its old info.

Thanks @nathanletwory, after un-install and re-install and some tinkering with adding the license to the rhino account it works. It took 3 attempts to add the license and now IE seems to be my default browser even when i disabled access to it :wink:

Automatic updates also work again.



That sounds… funky.

I use FireFox Nightly myself as default browser.

Same here, but even with these settings:


it opens IE when i click on “Check Now”. :confused:


I’m on Win10 these days, not sure how to help with that. The dialog form doesn’t seem familiar either - probably because I always used the FF “make default browser” button to do that for me.

If you open a command window in Windows, and type start http://www.rhino3d.com, which browser opens? I’m guessing it’s going to be IE. The code I write (this is an example of code I write) specifically uses the Windows shell to open URLs so that it uses the default web browser. It’s easier to write code that always uses IE - but I prefer Chrome, and always try to make Rhino use my (and your) favorite browser.


Yes, sometimes I miss the amber screen monitors from the mid '80’s.

Thanks @brian, it used IE. I’ve now found the registry key where IE is set as default browser :wink: