Can't Install Beta 6.0.17346.06021

unhandled

#1

So the latest Beta do not install on my desktop. Please wait… is all I can see with the story that goes nowhere. First tried to install from the automatic update, when that didn’t worked I manually downloaded it again form McNeel server but installation is no different. Please Wait… again and than nothing happens…
I’m on Win 7 ( 64 bit ).

Darius

Please Wait Beta


Why Same Icons
#2

To follow up on my original post. It seems that it actually got installed somehow in the background without me knowing anything about it. After typing my first message I went back and fired up my Rhino 6 expecting to see older version while in fact I got Dec. 12 opening up… not cool… but I’m glad it worked.

Darius


(Wim Dekeyser) #3

FWIW, lately, it’s been taking a long time (5 to 10 minutes) for the installer to do its thing around here as well.
I’ve been installing the Dec. 13th daily for a while now…


#4

Well I’d been sitting and waiting for about 5 min. before loosing my cool and canceling it. The interesting part is that despite update canceled the new Beta got installed anyway… :slight_smile:

Darius


(Brian Gillespie) #6

That’s weird. Is Rhino telling you “there’s an update available” and then running the installer again? Can you please send me a screen shot of the splash screen when the BETA starts, too?

Yuck. It sounds like the UI isn’t updating even though the installer is running in the background. Can you please zip up the last few days’ worth of log files from the installer and send them to me?

  1. In the address bar of My Computer, paste %temp% and press Enter
  2. Browse for files named Rhino_BETA_2017121*.log
  3. Put them all in a zip file
  4. PM me

(Wim Dekeyser) #7

I don’t understand that question - at least not the “again” part of it - I probably wasn’t clear (again). I didn’t repeatedly install the beta. The installer ran once but took a long time.

This morning I launched Rhino and there was no announcement of a new version.
I now went to Rhino Options > Updates and Statistics and see that the 17348.12501 is downloaded and ready to be installed.
Save and exit Rhino.
“An update is ready to be installed.” Pressed Yes
"User Account Control" dialog box. Pressed Yes at 07:44
"Please Wait" dialog.
Shortly after taking this screenshot, the dialog box disappeared - at 07:57

Interesting :imp:
I have almost 1 GB worth of Rhino_WIP_* and Rhino_BETA_* files in this TEMP directory. Why aren’t these cleaned up automatically?? I try hard not to drop under 5 GB of free space on this laptop…


#8

Hi Brian, I checked as you asked but there is no Rhino log file in “Temp” folder and going down the path C…Temp_McNeel_Rhino_V6_PreviewCache are all empty.
I searched C drive for Rhino log and found none.

Darius


(Brian Gillespie) #9

Looks like we’re all confused. What I’m trying to figure out is if Rhino 6.0.17348.12501 (the version in your screen shot and in the installer) is asking to install itself. It should not be that Rhino tells you there is an update if the version numbers match - but there have been bugs in this code before.

It sounds like the above description is not what is happening for you - I believe if it did, the installer would say “already installed”.

But it does sound like the installation process is taking a long time - 7 minutes and 44 seconds between “An update is ready to be installed’” and the user account control dialog? That’s really, really weird, and not something I’m seeing here.

Yeah, you install a lot of WIPs :slight_smile:

The trouble is that these are log files, and they’re there so that when you email tech support saying that something went wrong, we can get the log files and see what went wrong. If we automatically deleted them, that wouldn’t be possible. Perhaps it makes sense to clean up the logs automatically if installation is successful, however. (Logged as RH-43133).


(Brian Gillespie) #10

The temp file may not be C:\Temp. On my computer, it’s “C:\users\brian\appdata\local\temp” - did you look in a similar spot on your computer?


(Wim Dekeyser) #11

err… Yes :sunny:

No, it isn’t. I haven’t run into cases (during the last year or so) where a version is requesting to reinstall itself.

Err… No, not really.
I get the “An update is ready to be installed”, press Yes, wait a few seconds until the “User Account Control” dialog pops up and press Yes again. That was at 07:44 this morning. I suppose you would have written 7:44 a.m. In the next picture, I intentionally show part of the Windows OS Taskbar which includes the clock - 07:57. So, between I press the “User Account Control” dialog and when Rhino is completely installed, there are 13 minutes.

I read the OT as describing exactly that phenomenon.

I suppose I do :smile: At times a few dailies a day.

Well, why not just put them together with the downloaded executables? You guys are good and clean up after an install and there are never more than 2 versions left behind. When the next version has been installed successfully, you can safely delete those logs.


(Wim Dekeyser) #12

By the way. I’m running 17348.18291 now. I turned on the 'puter, ran Rhino, said yes to the update, hit yes on user account control, started Chrome to read discourse and before I knew, the Rhino installer was gone. That must have been within 1 minute or so. I’ll have to keep an eye on if the behavior is only manifesting itself at work where there might be network roadblocks.


(Brian Gillespie) #13

Can you send me some of those logs from around that time? You may have already deleted them, but the logs will (might?) show me where the slowdowns are happening.


(Wim Dekeyser) #14

Ha, I never delete anything :face_with_raised_eyebrow:
I’m including a file called DEL3532.tmp because that was created at 7:44 a.m. and that seems to fit…
Sending PM.


(Brian Gillespie) #15

Thanks @wim, here’s what I found:

[212C:0824][2017-12-15T07:51:25]i358: Pausing automatic updates.
[212C:0824][2017-12-15T07:57:31]w308: Automatic updates could not be paused due to error: 0x80080005. Continuing…

I don’t know what it means, but a 6 minute wait to pause automatic updates seems excessive. I’ve asked the fine folks at FireGiant (vendors who provide some core technology for the installer) what it means…


#16

Hi @brian, i do see this as well here since the last 6 or 7 updates. If i click yes to update the installation dialog starts immediately but the red progressbar does not move. Overall my installation takes between 15 - 25 minutes.

This would be great.

_
c.


#17

Several weeks ago I bought V6 license ( 6.0.18016 ), uninstalled WIP and run V6 installation which, surprisingly went as supposed with progress bar information updating as it progresses. Now with the new service release available, Rhino completely unaware of the update of course, so had to download manually, not a biggie, but when I tried to install, guess what, back to the old ways, or rather old glitches. Status bar again, “Please wait” and wait and wait and wait and nothing happens. Yet somehow after 10 minuets of frustration and several times opening rhino just to find out it is still 6.0.18 I finally get 6.1.1837…

If you ask about log files there are none ( C_User_AppData_Local_Temp_McNeel_Rhino_V6). I see PreviewCache and TextureCache forlders there but all empty.

Darius


(Wim Dekeyser) #18

Hi @brian, just checking if you are still following this one up. The installation of an update still takes 10+ minutes here. Installing 6.3.18059.19181 at the moment.


(Brian Gillespie) #19

@wim, here’s what we got back, translated slightly for human consumption:

The installer pauses the automatic updates service to prevent it from kicking in during the installation process. In our experience, the most common cause for a long pause is due to the automatic updates service or the underlying servicing stack being busy doing something (or at least thinking that they’re busy doing something).

To see if there is an automatic update in progress, read the logs in: %WINDIR%\Logs\CBS\CBS.log.

They say it’s possible to make the installer skip this step by running it from the command line and passing the “/nopause” switch. I don’t really want to do that from within Rhino, as the reasons for pausing the update system seem like sound ones to me.

But I do want to get back to Firegiant with your CBS.log if you can get one right after a long install.


(Wim Dekeyser) #20

Had a long install yesterday evening - 13 minutes. That seems to be consistent with what I reported earlier.

Note that quite a bit of this time is during the actual installation - i.e. after the long “Please wait” with empty progress bar (as in the picture in the very first post in this thread). It hangs quite a while as well during “Installing Rhinoceros 6 Language Pack Installer (en-US)” (as in my screenshot in post nr. 7).

Also, CBS.log has “Date modified” 2018-02-19. Sending in PM…