Installer won't install beta

I have the Nov 7 beta installed. Today I see Rhino reports new update to install
I click ok, nothing happens the installer goes away and hides and no update is installed. I click on the beta icon and the old beta opens but now no message to install an update.

Hi Roland - check Help > Check for updates - does that tell you you have a new one? It may have been getting a new version if that initial message was from last week… just a guess.


Hi Pascal,
Yep that must have been what happened. I just tried again and the latest beta installed itself, pretty cool that worked. I wish there would be a notification message in this case since I tried the install but Rhino failed. That appears like a bug to a user, Rhino should have reported downloading new version, not done nothing after a failed install because in this case it looks like a bad installation. Expecting a user to debug by waiting then checking the splash screen for latest updates seems error prone and was quite frankly something I forgot to check as well.

Which folder are these files downloaded to again? I want to see how many updates are on my drive because I need the space on c. I guess Rhino deletes some downloaded files but leaves it’s latest? If I have say three wip/beta install files that I don’t need I’d like to delete them.
Thanks for your quick help,

Hi Roland -



Thanks for that feedback. Logged as RH-42819.