Rhino BETA 2017-Nov-28 causes complete system crash

I just upgraded to the latest update and opened a file which runs perfectly in Rhino 5 and Rhino BETA 2017-Nov-14.

When I zoom to a particular part of the model

my whole system crashes, there is no “not responding” just a complete freeze, requiring a hard reset.

The model is too big to upload a the moment, I think the issue is caused by one of the curves, I will see if I can slim down the model and still recreate the problem and upload an update.


OK, definitely found the source of the problem, its a curved extrusion, the two images below show the viewing angle at which the crash occurs. One of them shows the curves displaying incorrectly, probably going off into infinity. Model is also attached…don’t blame me if your system crashes :wink:

Crash Example.3dm (822.5 KB)

Hi Jonny - thanks, I’ll check it - can you please run the SystemInfo command and paste the output here?
Works OK so far here, by the way - what exact command or function are you using when you crash it?


Hi Pascal, I am just orbiting around the object, no commands are active. I’ll try to record and upload so you can see.

System info:
OS Name Microsoft Windows 7 Professional
Version 6.1.7601 Service Pack 1 Build 7601
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name STORJO-LAP
System Manufacturer Dell Inc.
System Model Latitude E7450
System Type x64-based PC
Processor Intel® Core™ i7-5600U CPU @ 2.60GHz, 2601 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date Dell Inc. A04, 5/13/2015
SMBIOS Version 2.8
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = "6.1.7601.17514"
User Name SCHUCO-USA\storjo
Time Zone Eastern Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 10.7 GB
Total Virtual Memory 31.8 GB
Available Virtual Memory 26.2 GB
Page File Space 15.9 GB
Page File C:\pagefile.sys

Hi Jonny- thanks, I meant run the SystemInfo command in Rhino…


Got it :slight_smile:
Also here is a link to me recreating the crash, https://photos.app.goo.gl/r44WV43PwwqT4VCg1

Rhino 6 SR0 2017-11-28 (Rhino WIP, 6.0.17332.10241, Git hash:master @ 9359b47f5eb8d52c08ca047420e2fe6f08347939)

Windows 7 SP1 (Physical RAM: 16Gb)

Intel® HD Graphics 5500 (OpenGL ver:4.4.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.4
Shading Language: 4.40 - Build
Driver Date: 9-29-2016
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino BETA\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino BETA\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino BETA\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino BETA\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino BETA\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino BETA\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino BETA\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino BETA\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino BETA\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino BETA\Plug-ins\Displacement.rhp “Displacement”

Hi Jonny - can you please try updating your video card driver to the latest? it is over a year old. The video support is somewhat marginal, I guess, for Rhino - you might, just as a test, try turning off accelerated hardware modes - I don’t know if @jeff will approve (?) but you can set this in Options > Advanced page and type ‘OpenGL.UsehardwareDriver’ in the search box - set that to False and see if anything good happens- be prepared to switch it back though.


I don’t approve…That setting is a last ditch effort to confirm the GL system is to blame.

The first thing I would try @jstory is UNCHECKing the “GPU Tessellation” option in Rhino’s OpenGL settings page…and then see if you still crash.


Hi Jeff, unchecking “GPU Tessellation” seemed to solve the problem.

Is it best to keep this unchecked as a matter of course or only if I encounter problems?


Hi @jstory,

Well, we’d like it to remain checked always and forever… But every now and then a configuration pops up where our tessellation shader bombs…and we need to fix it…

So I’d like you to post a screenshot of Rhino’s OpenGL settings page so I can get a little more info about your Intel GPU.

But for now…if keeping it checked doesn’t work for you, then I would uncheck it and keep it that way until we can get a better handle on what’s happening with this particular config… It’s basically a major performance boost, so unchecking it you will see a slowdown…some cases probably not so bad, but there are other cases where you’ll probably see a pretty significant hit.


Hi @jeff,

OK, I’ll do some testing and see what happens. Here are my OpenGL settings.


RH-42887 is fixed in the latest BETA

@brian I just downloaded the latest BETA and still had the same issue as described in this thread. I’ll keep GPU tessellation turned off for now.


I just noticed that your Intel driver states that it supports OpenGL 4.4. I had thought this problem only existed with Intel drivers that support an OpenGL level below 4.4 so I disabled GPU tessellation by default for drivers at and below 4.3.

All we were really going to do is just disable the feature behind your back anyways. Hopefully we can figure out what is causing the Intel GPU drivers to crash -or- Intel comes out with an updated driver that fixes the situation.