Rhino 8 WIP on Mac: Import DXF Error

Hi al,

Just wanted to note a bug in Rhino 8 WIP on MacOS with M1:

If you try and “Import” a DXF file, I get an unspecified error:

File / Import…

Select a fairly small DXF (all flat, just lines)

Unspecified Error

Note also, the ‘Options’ button on the import dialog does not work either (so input for scale, etc…)

FWIW: this exact same DXF file imports perfectly well in Rhino-7, but obviously since Rhino7 is so, so, slow on M1 with lots of small objects (like CAD drawings) it would be great to be able to do the import and work in R8.

For now, the workaround is to import in R7, save, and then open in R8 to do what I need with the underlays.


  • Macbook 2021, Apple M1 Max
  • OS 12.3 (Monterey)
  • Rhino Version 8 WIP (8.0.22081.12306, 2022-03-22)

all the best,

Hi Ed -

I’m unable to reproduce that issue here but I’m on an Intel Mac.
Just to limit some of the variables here - does the same thing happen with files on your local disk (i.e. not synchronized on Dropbox)? Could you post a DXF file that behaves like that on your system?

Hi @wim

You bet: I created and saved a DWG and DXF to my desktop, but still get the same “Error” message:

for reference, the DWG/DXF files are attached as well (just a single rectangle):
Drawing1.dwg (31.2 KB)
Drawing1.dxf (210.8 KB)

FYI, I just updated to 8.0.22213.12306, and this is still giving me the Error.


Hi @ed.p.may ,

I tested that dxf file here on an M1 using the same WIP build and it works to open or import it. I wonder if it is the settings used… this is what I had set

Hi @BrianJ ,

Thanks so much for taking a look, that is really interesting…
for me: I don’t ever get any ‘options’, whether I ‘File/Import…’ or ‘File/Open…’ I get the normal dialog, with an ‘options’ button, but when I click it nothing happens…

I never see the screen you show there? How odd… The same thing happens whether I try import or open?


Just a shot in the dark here…

In Preferences > Plug-ins, ins the AutoCAD import plug-in enabled and loaded?

Hi @John_Brock

Thanks for the suggestion, looking at it now it does appear to be? Currently it shows me:


Try right clicking on it and select Load Plug-in
Does it load?

Thanks @John_Brock : When I right-click it shows me:

when I click ‘Load plugin-in’ in the context menu nothing seems to happen that I can tell? (it has a check mark next to it already though).

but it does not show up as ‘loaded’ on my system as it seems to on your screen shot there?

I can enable/disable ‘Load Protection’ though (if that means anything)

it seems to say Load-Time is ‘When needed’ under properties?


When you click “Load plug-in”, then it should say “Yes”

@John_Brock Ah - I see, no nothing happens at all when I click that?


That explains why it’s not working.
In Windows, I have the tools to trace back the dependencies.
In Mac I don’t have those tools.

The AutoCAD import plug-in won’t load in Ed’s WIP.
How do we trace that back through dependencies?

Hi Ed-

Thanks for all the info. I’d like to start by trying to determine if your issue is the same as this one (or not):

RH-67679 On Mac DXF/DWG Plugin is Enable but Not Loaded

Only one of us at McNeel is experiencing this :point_up: bug and we never got to the bottom of it, which is frustrating.

Can you please do the following for me?

  1. Quit the RhinoWIP (if it is already running).
  2. Launch the Console.app. (The easiest way to do this is to press Command+. to start Spotlight search and then type Console and press return.) Console lets us see the output of some back-of-house debugging messages).
  3. Click the Start button. This will start Console listening.
  4. Launch the RhinoWIP. This is when it loads all the plugins, like Import_ACAD.
  5. When it is done launching, start a new modeling window.
  6. Go back to Console and press the Pause button.
  7. In the search bar, type: Error loading and press return.

Does it show a Message from Rhino like:

Error loading /Applications/RhinoWIP.app/Contents/PlugIns/import_ACAD.rhp/Contents/MacOS/import_ACAD:  dlopen(/Applications/RhinoWIP.app/Contents/PlugIns/import_ACAD.rhp/Contents/MacOS/import_ACAD, 265): Library not loaded: TD_DbEntities.tx
  Referenced from: /Applications/RhinoWIP.app/Contents/Frameworks/ATEXT.tx
  Reason: image not found


If you click on an error in the list, it will show the full error at the bottom of the screen. There might be 3 of these, if you are experiencing the same bug as listed above. Can you please copy/paste the text in here if you are seeing them?

Thank you in advance,

Hi @dan Thanks for taking a look at this. And yes you bet: happy to try that out. I closed everything else and tried to capture the Console sessions as quickly as possible while opening Rhino 8 WIP. So this is what it shows me when I filter for “Error”:

that “MacOS Error - 25294” goes on for a long while (all the same text). And then it does show one warning message that looks like:

and then when I click to ‘Errors and Faults’ I see:

I have done a full copy past of all 186 messages and attached here:
Console - Rhino 8 WIP Startup Full Error Log.txt (73.1 KB)

and all 65 Warning / Errors:
Console - Rhino 8 WIP - Error and Warning Full.txt (72.4 KB)

and then I copy/pasted the body from that 12:01:14.665209-0400 error as a separate txt doc as well, to hopefully make that a little easier:
Console - Rhino 8 WIP Startup Error 12-01-14-665209-0400 Error Log.txt (32.8 KB)

hopefully those .txt documents come through correctly? Just let me know if not and I’ll try again. If there is anything else from that I can provide just let me know and I’d be happy to of course.

all the best,


Oh - also: I just tried doing the same thing (Console, start / pause) executing that AutoCad import command. If its helpful, that action resulted in the following:

filtering for ‘Rhino’

Console - AutoCad Import - Rhino Messages.txt (16.7 KB)

and then filtering for ‘Error’

Console - AutoCad Import - Error Messages.txt (4.9 KB)

just in case that provides any additional information there.


Yes! Thank you Ed. This is very helpful. It confirms that you are experiencing the same thing as:

RH-67679 On Mac DXF/DWG Plugin is Enable but Not Loaded

or very similar; I will need to read through the logs looking for details.

Our immediate goal is to try to figure out how to reproduce this on a computer we can debug it on.

We think we might be making some progress on this issue :crossed_fingers: perhaps we’ll have something to test in this weeks WIP if all goes well.

Great! Thanks @Dan
I’ll be excited to take a look as soon as you think its ready.

Well, we missed a week of RhinoWIP builds unfortunately due to reasons beyond our control. I really hope we get another RhinoWIP out next week with this fix in. In the meantime, you are welcome and encouraged to test out a “daily build” of the RhinoWIP with this fix in it (though it may be even less stable than a typical WIP). You might consider just putting it on your Desktop and testing it from there and deleting it after. Regardless, the fix should be in next week’s WIP.

Hi @Dan,

Just FYI: I just tested with the new WIP (8.022166.04306) and looks like it is working well now with DWG and DXF imports. Thanks so much!