Rhino 8 Vector Printing Broken?

Loving Rhino 8. Any news on when this issue will be resolved?

1 Like

Hi Rob -

I see two issues being referred to in this thread. When these get resolved, this thread will be notified. Both reports are public, and you can always check for activity. As of now, both are on the 8.x list.
-wim

Just to get notified when this printing issue is resolved, so i can upgrade my license to R8. Same problem using rhino_en-us_8.3.24009.15001 eval (for Windows 10 AND Mac OS 12.7.3 too)
when printing using Rhino pdf of a pen display with vector output.
Project file developed with R7 and no printing issue with R7
Thanks

Hi -

Before anything else, please update to the Rhino 8.4 release candidate.

Which issue is that, specifically?

I’m sure you know that, but in Rhino 7, there was no vector output from viewports in pen display. Doesn’t raster output in Rhino 8 give you the same as it did in Rhino 7?
-wim

Hi Wim and thanks for your reply.
Just checked by opening R7, i do have the choice between Vector and Raster output (File/Print/Rhino pdf) .
The Raster output is not adequate, either in R7 or R8.
Printing a layout with several viewports and both pen and rendered displays, issue only with the pen display
With R8 despite the same settings (also tried to increase resolution) some lines are missing, which is not the case with R7. Tried to explode blocks, ungroup groups, etc … at no avail.
Re R8 version i only have the eval so far (hope to purchase it before the promotion is ending this month) and when i go to the download page can only get R8.3 . How can i update to R8.4 ?
Thanks

Hi -

Yes, of course. But what I said was:

You didn’t mention a layout in your first post. Layouts are set to the “Wireframe” display mode, and when printing a layout as vector output, all curves, hatches, and annotations that are created on the layout will be printed as vector. If you were to create a surface on the layout, you’d get vector output of the edges and isocurves, but no “surface” (color, shading, …) will be printed.

When you put a detail on a layout, you typically set the display mode of that detail to some “shaded” display mode. Up until Rhino 7, whatever display mode (apart from Wireframe) you picked, that detail will always be printed as raster, also when vector output is selected.

You should probably provide a layout from Rhino 7 with non-wireframe details, but are you referring to geometry on the layout or geometry you see in a detail on a layout?

What is new in Rhino 8 is that any detail on a layout that is set to any of the technical display modes (Technical, Pen, Artistic, Monochrome, and any modified copies of those) will result in vector output when printed as vector. This is something that has been on the wishlist for over 25 years, and, yes, is not completely perfect yet.

For the time being, if you are happier with raster output of details on a vector layout than somewhat unfinished complete vector output, you could modify a rendered or shaded display mode to look somewhat more like a pen mode.

In the Rhino Options, change the update frequency from “Service Release” to “Service Release Candidate”.
-wim

Thanks
Just updated to R8.4 but still facing the same issue. No problem with annotations (e.g. dimensions, hatches, etc) added on the layout. Layout including 3 windows. When double clicking on the “pen” window, i get :
Active viewport : Detail (top), Display mode : Pen (other display modes not meeting this project needs)
So believe this is what is referred as geometry in a detail on the layout. The rendering and pdf printing of the 2 other windows with display mode rendered are OK.
Selecting “Vector output” some lines do not show up with R8 while OK with R7 despite identical settings. With the raster output option these lines are not missing anymore but overall quality print not as sharp…
Unfortunately i am not allowed to send any of these client files, but will see if i can replicate with a smaller non proprietary model the same issue.

I just found a similar issue with R8.4 release version on Windows 10 trying to print (generating a pdf with Rhino pdf) and Vector Output of a polysurface made of several surfaces for instance a structure made of several tubes/pipes joined together using a boolean union or several planar surfaces joined together plus filleted edges. I took the top viewport with the pen display. Most of the lines are missing even in the preview and hence in the generated pdf too.
Once i explode these polysurfaces (into 45 or 86 surfaces for the latter) it works fine, but obviously cannot do that with a more complex model including a lot of polysurfaces and blocks !
Hope this can help you troubleshooting this printing default.

Hi @wim,

I found a new related issue to RH-79539. While non-block lines are correctly drawn when printing vector mode in the copy of 8.5 I was using as a hold-over, textured surfaces (imported images) get drawn through the solid objects:

As before, this is not an issue in raster:

Unfortunately, many of our clients still require vector PDF even if there are raster components in there.

Any chance you and Matthew Sorensen could have another crack at the issue soon? I’ve just bought a new R8 licence since we have a new staff member and he isn’t able to save as R7 with VisualARQ for printing. It’s causing a bit of trouble for us trying to work around the issue.

@wim, @Gijs. @Matthew_Sorensen just checking to see if any new work is planned to address this issue?

As mentioned, we have a workaround (which adds time and complexity to printing) for some of my staff, but the new guys who only have Rhino 8 are stuck being unable to print vector. For technical drawings (which is 95% of our output), raster is not acceptable. If Rhino 7 was still for sale, I’d almost be okay setting up everyone with the workaround through VisualARQ2 too, but Rhino 8 was announced as having the feature and when I tested it near the end of last year, it worked. The trick of exploding blocks to get them to print in vector in Rhino 8 does not work on large models, since exploding massively increases model size and causes crashes.

Can we please get this fixed soon or some kind of estimate of when it could be fixed at least? My business relies on being able to put out top quality vector technical drawings. I understand fixing these bugs take time and you have other issues to work on, but it’s been weeks with nothing new and no discussion.

If the licenses of the “new guys” are full V8 licenses, you can get free “legacy” V7 licenses via the McNeel website as a workaround…

1 Like

Thanks @Helvetosaur,
Just tried it and it works. Hopefully the team has some good things planned though since I wasn’t expecting to have the need to buy more VisualARQ2 licences. This at least gives me a fall-back and I appreciate the pointer.