Rhino 8 SRC 8.8 Bug: Rendered and Raytraced display modes not working

As per topic, Rendered and Raytraced display modes stopped working after installing SRC 8.8.24138.16021. Both views doesn´t render (show) the 3D model, just a white viewport. I rolled back to SRC 8.7.24113.23001 and both display modes are working fine again.

System info:

MSI GT76 Titan DT9SG
OS: Windows 10 Pro 64-bit, version 22H2, OS build 19045.4412
CPU: Intel(R) Core™ i9-9900K
GPU: NVIDIA RTX2080 8GB - Driver version 526.86
RAM: Kingston HyperX 32GB

Please run the Rhino command _SystemInfo and post the result in a reply.

Rhino 8 SR7 2024-4-22 Rhino 8, 8.7.24113.23001
License type: Commercial, build 2024-04-22
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [57% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 1-22-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 2080 (NVidia) Memory: 8GB, Driver date: 11-8-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 526.86
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-8-2022
Driver Version: 31.0.15.2686
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24113.23001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Users\Omeninho\AppData\Roaming\McNeel\Rhinoceros\packages\8.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

You need to update your GPU driver. The latest at the moment for your GPU is Driver Details | NVIDIA . When you install make sure you choose Custom/Advanced Installation and check the Clean Installation checkbox.

After that you should be able to use Rhino 8.8 with Rendered mode and Raytraced just fine.

Is this driver update required due to “something” that was addressed in 8.7 or more a generic response like “try updating your GPU drivers”?

Just for context, laptop GPU drivers are very finicky and all CAD/CAM/CAE softwares I have installed are running rock solid at the moment. The last thing I would want to do is mess with a more recent NVIDIA driver that could potentially bring all kind of mayhem to my installed softwares (as it happened before).

1 Like

@nathanletwory : No joy. I just installed the newest drivers and the issue persisted. As I said, with SRC 8.7 everything works fine again.

p.s. I uninstalled GPU drivers with NVIDIA DDU uninstaller + “clean installation” checked afterwards.

Pre 2024 drivers for Nvidia GPU are known to even crash Rhino. I suppose you’re lucky that you only see white viewports. Raytraced and Rendered mode definitely work, so we need to figure out what the difference is. Updating the driver to the latest whilst ensuring a clean installation is one step in minimizing the amount of variables to investigate - Windows updates are known to mess up driver installations.

To further verify that Raytraced can properly work check Tools > Options > Rhino Render (Not Tools > Options > Render). Does the tabbed panel in the middle show a green dot for the Nvidia GPU? It looks something like this

If it does change the render device to CPU and see if Raytraced starts showing something.

If that works then please do the following steps:

  1. Tools > Options > Advanced. Type VerboseLogging and set it to true
  2. Change render device to CUDA
  3. restart Rhino
  4. add a box,
  5. switch the perspective viewport to Raytraced, after a say 10-20 seconds (assuming it stays just white)
  6. switch back to wireframe
  7. change device again to CPU
  8. switch perspective viewport to Raytraced
  9. Once it is finished run the command RhinoCyclesShowLog and post the result here.

If changing to CPU didn’t do anything then please hit the Recompile kernels button and wait for the dot to turn green. If after 30 minutes it is still orange hit the Show compile log button and post the result of that instead.

Of course, it’d be prudent to update also your Intel GPU driver. Whilst you have the Nvidia GPU set as the main OpenGL device it still can impact drawing.

I´ll update to 8.8 again and try it out. Right now CUDA shows a green dot.

I found out that this issue might be related to the custom preview component. If I open a GH file that has breps or meshes connected to a custom preview component (99% of my files), both display modes doesn´t work. Now, if I disconnect and connect them again to the custom preview component, both Rendered and Raytraced display modes starts to work as intended.

Switching to CPU render displays the same behavior.

1 Like

Interesting bit of info, thanks!

When I get the chance I’ll verify and log a bug.

1 Like

No problem, @nathanletwory. Glad I could be of help.

p.s. whenever possible, could you please take a look into this as well? This little bug is still present on 8.8.

Rhino 8 SRC 8.4: Artistic and Monochrome display mode Bug - Grasshopper - McNeel Forum

I was able to reproduce both issues in Rhino 8.9 (internal build). I don’t think it is the custom preview component per se, but rather the Create Material component. Or probably them both together.

Here my findings in video, will create a bug report soon:

Logged as RH-82108 Custom Preview and Create Material cause display issues

1 Like

Much appreciated, @nathanletwory.

Probably facing the same issue. I added my observation here: Rhino 7 and Rhino 8 Grasshopper - Custom Preview Component Issue - #3 by PetrVacek

No need to cross-post. And as mentioned in the other thread: the bug is still not fixed. See the shared YouTrack link.

Okay, thanks. Topic merge possible?

Any chances to have this resolved till Friday? Could you give me some estimation? I am a contractor of a company where this issue unfortunately broke our workflow and we have to wait with a release of new features until this is resolved… :frowning:

I don’t know when this gets resolved, but quite certain not before Friday. If there is no new functionality in 8.7 and 8.8 that your workflow relies on you could downgrade to 8.6 where I believe this still worked.

1 Like