Rhino 8 randomly freezes while doing nothing out of the ordinary

Hey.

I’ve been experiencing this issue just for the past few hours. Rhino randomly freezes while doing pretty normal things like paning or moving objects.
Sometimes it happens only once an hour, sometimes every 20 to 30 seconds.

When it freezes i cant do anything, not even close it.

Then I wanted to stop it via the task manager and for some weird reason opening the task manager makes rhino work again. Until it freezes again.

I have no idea why this is. The files I’m working in are relativly heavy (like 300-500 mb) but that didnt cause any problems until today.

Any help appreciated. Or maybe just someone else experiencing the same issue

SystemInfo:

Rhino 8 SR7 2024-5-17 (Rhino 8, 8.7.24138.15431, Git hash:master @ 03702f889bdef32626af4bca510b5e8a85666d38)
License type: Educational, build 2024-05-17
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.7

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 6-15-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port 1
Primary OpenGL: NVIDIA GeForce RTX 3050 Ti Laptop GPU (NVidia) Memory: 4GB, Driver date: 5-13-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 555.85
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-13-2024
Driver Version: 32.0.15.5585
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino8.rhp “Karamba3DLicense”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 5.3.2.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 8\Plug-ins\export_OBJ.rhp “export_OBJ” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Hi Ruben, Please run the SystemInfo command in Rhino and post your results. Thanks

Hey, yes of course. Sorry.

Rhino 8 SR7 2024-5-17 (Rhino 8, 8.7.24138.15431, Git hash:master @ 03702f889bdef32626af4bca510b5e8a85666d38)
License type: Educational, build 2024-05-17
License details: Cloud Zoo

Windows 11 (10.0.22631 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.7

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 6-15-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1
Primary OpenGL: NVIDIA GeForce RTX 3050 Ti Laptop GPU (NVidia) Memory: 4GB, Driver date: 5-13-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 555.85
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-13-2024
Driver Version: 32.0.15.5585
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Karamba\License\Karamba3D_LicensePlugin_Rhino8.rhp “Karamba3DLicense”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 5.3.2.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 8\Plug-ins\export_OBJ.rhp “export_OBJ” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Can you repeat the issue without plugins loaded? Go to File>Properties>Plugins and sort by 3rd Party plugins and disable, restarting Rhino is req’d.

Just tried that, rhino still freezes.Also all the plugins where installed for a few weeks now and i only experience this issue since today :confused:

Thanks, it was a longshot but always the first thing to try, your video card configuration looks fine.

I’m going to send you our latest in a pm to see if that affects anything.

Thank you, just installed it. Sadly it happened again after modelling for a few minutes :confused:

Can you repeat in Safe Mode? To open Rhino In Safe Mode search in Windows Run dialog.

The shortcut is typically located here if it doesn’t come up in search…

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Rhino 8

In safe mode its going to run without video driver or plugins. So hopefully this can narrow it down a bit. Thanks

Another thing we can try is to capture a dmp while it is frozen from the Task Manger like so…

https://wiki.mcneel.com/rhino/manual_rhino_dmp_windows

I have now tried for like half an hour to get it to happen in safe mode but it didnt. I have the dmp, Should i just sent it like its explained on the site you linked?

Yes please. Add a link to this thread as well in the comments. Thanks

https://www.rhino3d.com/upload

That points to a video card driver.

Grab the latest From nvidia and install it using the custom/advanced option , the. Hit the clean install checkbox and finish the install.

Restart and try rhino again normally.

One thing to note, Nvidia has a studio driver, and a game ready driver. Depending on your system, one may work better than the other, if you’re using the Studio driver try the game ready or vice versa.

This is looking more and more like the GPU Tessellation issue again.

Please turn OFF GPU Tessellation in Rhino’s Options->View->OpenGL and then restart Rhino…and see if things get any better.

-Jeff

2 Likes