Rhino 8: Polyline drawing lags behind the cursor

The lag still accumulates, but noticeably less so than before this SR.

@anon @Czaja one thing that I notice is that you are both using the 551.61 driver. I’m using
Driver date: 1-2-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 538.18

If I am correct the one you are using are Game Geforce drivers.

Is there a particular driver package I’m supposed to be using?

NVIDIA RTX / Quadro Desktop and Notebook Driver Release 550 | R550 U5 (552.22) | Windows 10 64-bit, Windows 11 | NVIDIA seems to the latest for p2000

be sure to clean install

I have a 4070 here with 552.22 installed (studio driver) and I can’t see any lag - in any case as fast as I can click my mouse.

Clean installation, no change in cursor lag.

SystemInfo-R8

Rhino 8 SR8 2024-5-14 (Rhino 8, 8.8.24135.14001, Git hash:master @ 8c191427bc5c6c4e62f523a752d809f68897c3a5)
License type: Commercial, build 2024-05-14
License details: Cloud Zoo

Windows 10 (10.0.17134 SR0.0) or greater (Physical RAM: 16GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 2-18-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version: 31.0.15.5222
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Maybe clean install alone is not enough. See Rhino freezes and crashes on NVidia video card - #4 by D-W

The same with disabled 3rd party plugins. Didn’t test the drivers yet.

Can you help with a little translating of that post? What exact steps should I take?

@Czaja and @anon what is the make and model of your mouse? There are some “gaming” models that emit events at a very high frequency and I want to eliminate that as a possibility.

Microsoft Classic Intellimouse for me.

Thanks for looking into it

ok, well that’s definitely not the cause then

@Czaja and @anon please post a screenshot of your Rhino. I want to see if there are any customizations made that are different than what I’ve tested so far.
Thanks,
-Steve

A screenshot of the window?

SystemInfo-R8

Rhino 8 SR8 2024-5-14 (Rhino 8, 8.8.24135.14001, Git hash:master @ 8c191427bc5c6c4e62f523a752d809f68897c3a5)
License type: Commercial, build 2024-05-14
License details: Cloud Zoo

Windows 10 (10.0.17134 SR0.0) or greater (Physical RAM: 16GB)
.NET 7.0.0

Computer platform: LAPTOP - Plugged in [99% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 2-18-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version: 31.0.15.5222
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.8.24135.14001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

Yes, thanks. That is very different than the default layout. I will try to mimic that layout to see if it makes any difference

Was there a setting you had to toggle to allow the layers panel to dock all the way to the top like you show in the screenshot?

[edit]: never mind. Gijs pointed out that it is Rhino.Options.Advanced.UseEntireWidthForTopBand

While using Rhino 8 in Safe Mode there is significantly less lag (almost non-existent) but you can still see that it eventually builds up and while I’m making the third lap it starts becoming apparent.


That’s really tough to compare against as safe mode strips out a ton of different things. Can you provide an update of your original video in this thread using 8.8? I’m interested to see the build up in lag as points are added.

Also @Czaja please send me your settings-Scheme__Default.xml file. This can be found at
%AppData%\McNeel\Rhinoceros\8.0\settings
in file explorer.

Thanks,
-Steve

Using Rhino 8.8.24137