Rhino 8 make2d is behaving strangely for my model

I am currently trying to make2d this top view of my model with a clipping plane to make a floor plan, but everytime I try to make2d it does this:

I have no idea what is causing this, and its repeatable.

I am using Rhino 8. I first thought that it could have been a problem caused by me using a lot of nested block instances, but even after exploding each block I still encounter the same issue. Weirdly it doesn’t happen when I try to make2d only one square, but when I try again with more at once the same problem occurs. There are also random weird missing lines.

Diagram file fixing.3dm (17.8 MB)

Here is the file, its rather large. Please help! My archi final presentation is in 10 days…

Hi Marcus -

There are no hidden or locked layers or objects in the file you posted, but there is no clipping plane in this scene.

I’ve added a clipping plane and wasn’t able to notice anything wrong with the Make2D output. You don’t say it in clear text, but I assume the problem on your end is the long red horizontal and vertical lines?

Please run the Rhino SystemInfo command and copy-paste the result here.

Hello, thank you for the prompt reply. My apologies… I exported that part of my file to post here and must have forgotten to include the clipping plane. Yes the long lines stretching to infinity is the issue I’m trying to resolve. I’ve just downloaded Rhino 7 on the same computer and exported the file as a Rhino 7 3dm, and I managed to successfully make2d with no issues. The problem seems to only occur on Rhino 8.

Anyhow, heres the systeminfo you’ve requested:

Rhino 8 SR5 2024-3-12 (Rhino 8, 8.5.24072.13001, Git hash:master @ e3530849b75f00b2b977766a567ae29b055837e9)
License type: Educational, build 2024-03-12
License details: Cloud Zoo

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.14

Computer platform: DESKTOP 

Standard graphics configuration.
  Primary display and OpenGL: NVIDIA GeForce RTX 4060 (NVidia) Memory: 8GB, Driver date: 7-12-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 536.67
    > Accelerated graphics device with 4 adapter port(s)
        - Windows Main Display attached to adapter port #0
        - Secondary monitor attached to adapter port #1

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Graphics level being used: OpenGL 4.6 (primary GPU's maximum)
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: High
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 7-12-2023
  Driver Version:
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 8188 MB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
  D:\Plug-ins\Commands.rhp	"Commands"	8.5.24072.13001
  D:\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  D:\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	8.5.24072.13001
  D:\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	8.5.24072.13001
  D:\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  D:\Plug-ins\MeshCommands.rhp	"MeshCommands"	8.5.24072.13001
  D:\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	8.5.24072.13001
  D:\Plug-ins\RhinoCode\RhinoCodePlugin.rhp	"RhinoCodePlugin"	8.5.24072.13001
  D:\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	8.5.24072.13001
  D:\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  D:\Plug-ins\Displacement.rhp	"Displacement"	
  D:\Plug-ins\SectionTools.rhp	"SectionTools"

Your Nvidia driver is quite old by Rhino 8 standards. I suggest you update it even if it turns out it doesn’t fix your specific problem.

Hi Marcus -

Please provide a 3dm file that you can reproduce the issue with. If that means that a larger file or proprietary geometry is needed, please upload that file from Rhino - Upload to Support