Random rectangles bug when doing Make2D

I’m trying to do Make2D on my model. Just selecting everything and performing the command in this view:


These are my settings:

Normally make2D has been working fine, but recently I am getting this strange and useless output when I do it:

After seeing this happen (repeatedly) I tried Make2D in another view that I know has worked in the past. In this instance I did get the output I was looking for, but it also had these strange lines in addition to it. This hasn’t happened before.

Not really sure what’s happening.

Hello- please post a model or send to tech@mcneel.com, with a link to this topic in your comments…
Is the geometry very far from the world origin by any chance?

-Pascal

I had this same problem yesterday - Rhino 8 for Mac. The main problem was an open polysurface that I was cutting through with the clipping plane. (There might also have been a problem with unexploded blocks also on the clipping plane). The fix was simply to close the poly.