Make 2d issue

make2d
#1

HI all

I am having some issues with make 2d in rhino 6 - it just doesnt seem to want to make 2d my model. I have a clipping plane. It has been working perfectly up until a week or so back. I can make 2d the same file in mac but I want to do it in windows to easily line it up with my renders. I seems weird that I simply doesnt produce the file

Make2D bug fix
(Rickson) #3

I’ve been having issues today as well, apparently Parallel Views only like certain clipping planes. Not sure if its a bug or feature.

#4

Hi,
Same issue here: Make2d on ‘Left’ or ‘Rear’ view won’t produce any drawing (see file attached).


issue clippingplane.3dm (41.4 KB)

(Greg Arden) #5

A bug was introduced in 6.14. It should be fixed in the next service release candidate ( due out today if things go as planned). Please let me know if this fixes your issue.

1 Like
#6

Hi Greg,

Thanks, I tested with the new release (6.14.19098.19271) and the file above: it seems to work so far. :slight_smile:

(Rickson) #7

would this issue/update apply to Grasshopper as well? I get an error any time i put in a non-horizontal plane to Parallel Make2D View.

#8

Having updated it to the latest version of Rhino I am still having some serious issues. all are closed polysurfaces - It doesnt want to make 2d any of it!!!

(Pascal Golay) #9

Hello - is this also dependent on clipping planes being active?

-Pascal

#10

Hi there the clipping plane is active

you can have a look at the file here - https://www.dropbox.com/s/rw0tia2a221mvhn/SECTION%20CRIT2.3dm?dl=0

There is some issue with that wont let it make 2d

(Pascal Golay) #11

Hmm - the model is vast

473680.287 millimeters

and modeled in mm at .001… that may come into play - I get results but not the right ones, with or without the clipping plane.

But, ExtractRenderMesh and Make2d of that does seem to do the right thing here - might be ok for now. But, get the 6.14 release candidate - Options> Updates and Statistics page > Update frequency > Service release candidate. I will add your file to a new bug track item…

https://mcneel.myjetbrains.com/youtrack/issue/RH-51990

-Pascal

1 Like
#12

I am assuming by your comments that reducing the tolerance and possibly changing the units should have some impact on the outcome. for reference I model mostly on my mac and then only use rhino on windows for make 2ding and rendering. Could this crossover have some impact - bringing rhino 5 models into 6?

(Pascal Golay) #13

Hello - I don’t know that but I did notice the huge numbers and tiny units… Make2d is sensitive to tolerance. Since he meshes do make the right curves, I can’t say that is the critical issue though.

-Pascal